aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sparse
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/sparse
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/sparse')
-rw-r--r--packages/sparse/.mtn2git_empty0
-rw-r--r--packages/sparse/files/.mtn2git_empty0
-rw-r--r--packages/sparse/files/compile.patch16
-rw-r--r--packages/sparse/files/vars.patch42
4 files changed, 58 insertions, 0 deletions
diff --git a/packages/sparse/.mtn2git_empty b/packages/sparse/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/sparse/.mtn2git_empty
diff --git a/packages/sparse/files/.mtn2git_empty b/packages/sparse/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/sparse/files/.mtn2git_empty
diff --git a/packages/sparse/files/compile.patch b/packages/sparse/files/compile.patch
index e69de29bb2..f19d521335 100644
--- a/packages/sparse/files/compile.patch
+++ b/packages/sparse/files/compile.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sparse-bk/expression.c~compile 2004-09-13 17:42:22.642639000 -0400
++++ sparse-bk/expression.c 2004-09-13 17:44:59.147847520 -0400
+@@ -8,7 +8,7 @@
+ *
+ * This is the expression parsing part of parsing C.
+ */
+-#define _ISOC99_SOURCE
++//#define _ISOC99_SOURCE
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <stdio.h>
diff --git a/packages/sparse/files/vars.patch b/packages/sparse/files/vars.patch
index e69de29bb2..353df2ad0b 100644
--- a/packages/sparse/files/vars.patch
+++ b/packages/sparse/files/vars.patch
@@ -0,0 +1,42 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- sparse-bk/Makefile~vars 2004-09-13 17:45:43.304134000 -0400
++++ sparse-bk/Makefile 2004-09-13 17:46:04.980839384 -0400
+@@ -1,4 +1,5 @@
+ CC=gcc
++CCLD=gcc
+ CFLAGS=-O -g -Wall
+ LDFLAGS=-g
+ AR=ar
+@@ -26,22 +27,22 @@
+ if test $< -nt $(PREFIX)/bin/sparse ; then install -v $< $(PREFIX)/bin/sparse ; fi
+
+ test-lexing: test-lexing.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ test-parsing: test-parsing.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ test-linearize: test-linearize.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ compile: compile.o compile-i386.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
+
+ obfuscate: obfuscate.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ check: check.o $(LIB_FILE)
+- gcc $(LDFLAGS) -o $@ $< $(LIBS)
++ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ $(LIB_FILE): $(LIB_OBJS)
+ $(AR) rcs $(LIB_FILE) $(LIB_OBJS)