aboutsummaryrefslogtreecommitdiffstats
path: root/packages/spca5xx
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@yahoo.com>2006-02-20 20:32:25 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-20 20:32:25 +0000
commita953f708d91b5ec953bcce9eaec0197729891b3e (patch)
treee7c87107ddd7f79f1c0ea1429a2bfd3d3e63b6fa /packages/spca5xx
parentba81094a28b35db729737a391e266c92ecf588e4 (diff)
downloadopenembedded-a953f708d91b5ec953bcce9eaec0197729891b3e.tar.gz
spca5xx: added release 20060202 (on request, builds fine, cannot test this as I do not have this cam)
Diffstat (limited to 'packages/spca5xx')
-rw-r--r--packages/spca5xx/spca5xx-20060202/.mtn2git_empty0
-rw-r--r--packages/spca5xx/spca5xx-20060202/Makefile.patch19
-rw-r--r--packages/spca5xx/spca5xx_20060202.bb27
3 files changed, 46 insertions, 0 deletions
diff --git a/packages/spca5xx/spca5xx-20060202/.mtn2git_empty b/packages/spca5xx/spca5xx-20060202/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/spca5xx/spca5xx-20060202/.mtn2git_empty
diff --git a/packages/spca5xx/spca5xx-20060202/Makefile.patch b/packages/spca5xx/spca5xx-20060202/Makefile.patch
new file mode 100644
index 0000000000..8053858ee1
--- /dev/null
+++ b/packages/spca5xx/spca5xx-20060202/Makefile.patch
@@ -0,0 +1,19 @@
+*** spca5xx-20060202/Makefile.orig Thu Feb 2 21:33:18 2006
+--- spca5xx-20060202/Makefile Sun Feb 19 12:39:35 2006
+***************
+*** 51,57 ****
+ default:
+ @echo ' Building SPCA5XX driver for 2.5/2.6 kernel.'
+ @echo ' Remember: you must have read/write access to your kernel source tree.'
+! $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC=$(CC) modules
+
+ install:
+ mkdir -p $(MODULE_INSTALLDIR)
+--- 51,57 ----
+ default:
+ @echo ' Building SPCA5XX driver for 2.5/2.6 kernel.'
+ @echo ' Remember: you must have read/write access to your kernel source tree.'
+! $(MAKE) -C $(KERNELDIR) SUBDIRS=$(PWD) CC="$(CC)" modules
+
+ install:
+ mkdir -p $(MODULE_INSTALLDIR)
diff --git a/packages/spca5xx/spca5xx_20060202.bb b/packages/spca5xx/spca5xx_20060202.bb
new file mode 100644
index 0000000000..a5798f5b59
--- /dev/null
+++ b/packages/spca5xx/spca5xx_20060202.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "USB Webcam driver for spca5xx chipset family supporting \
+over 100 models of camera""
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+MAINTAINER = "dyoung <dyoung8888@yahoo.com>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://mxhaard.free.fr/spca50x/Download/spca5xx-20060202.tar.gz \
+ file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/spca5xx-20060202"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KERNELDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}
+