aboutsummaryrefslogtreecommitdiffstats
path: root/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2008-01-05 16:44:14 +0000
committerMatthias Hentges <oe@hentges.net>2008-01-05 16:44:14 +0000
commit1281530838d3bfd8ba09e3d4ad5ecf69a7ba8239 (patch)
tree58233678f5bea81316024b51896b0957c2e86206 /packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
parent102a2ccf962e5d85f50a7eb82821879948eaa8db (diff)
downloadopenembedded-1281530838d3bfd8ba09e3d4ad5ecf69a7ba8239.tar.gz
speech-dispatcher: Fix packaging of configfiles
Diffstat (limited to 'packages/speech-dispatcher/speech-dispatcher_0.6.5.bb')
-rw-r--r--packages/speech-dispatcher/speech-dispatcher_0.6.5.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
index 4b49870665..d8e2b8ed3a 100644
--- a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
+++ b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
@@ -5,7 +5,7 @@ LICENSE = "GPLv2"
DEPENDS = "flite libdotconf glib-2.0"
RPROVIDES_${PN} += "speechd"
-PR = "r4"
+PR = "r5"
inherit autotools update-rc.d
@@ -24,9 +24,10 @@ do_install() {
install -d ${D}${bindir}
install -d ${D}${includedir}
install -d ${D}${libdir}/${PN}-modules
- install -d ${D}${sysconfdir}
- install -d ${D}${sysconfdir}/modules
+ install -d ${D}${sysconfdir}
install -d ${D}${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/speech-dispatcher
+ install -d ${D}${sysconfdir}/speech-dispatcher/modules
oe_libinstall -so -C src/audio libsdaudio ${D}${libdir}
oe_libinstall -so -C src/c/api libspeechd ${D}${libdir}
@@ -37,8 +38,8 @@ do_install() {
install -m 0755 ${S}/src/server/.libs/speech-dispatcher ${D}${bindir}
install -m 0755 ${S}/src/modules/.libs/sd_* ${D}${libdir}/${PN}-modules/
- install -m 0644 ${S}/config/speechd.conf ${D}${sysconfdir}
- install -m 0644 ${S}/config/modules/*.conf ${D}${sysconfdir}/modules
+ install -m 0644 ${S}/config/speechd.conf ${D}${sysconfdir}/speech-dispatcher
+ install -m 0644 ${S}/config/modules/*.conf ${D}${sysconfdir}/speech-dispatcher/modules
install -m 0755 ${WORKDIR}/speech-dispatcher.init ${D}${sysconfdir}/init.d/speech-dispatcher
}