aboutsummaryrefslogtreecommitdiffstats
path: root/packages/speech-dispatcher
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-07-20 12:24:19 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-07-20 12:24:19 +0000
commita2f3bda7c838e1e5750e0ea96096f2b3de6590fe (patch)
tree698805e5905f428b534b0f2f1ed28b9b0d63bf41 /packages/speech-dispatcher
parent3223fbd9a2002c79ba09633596c70e5f483094d4 (diff)
downloadopenembedded-a2f3bda7c838e1e5750e0ea96096f2b3de6590fe.tar.gz
speech-dispatcher: fix configure.in for c++
* we have a little patch that has support for espeak * the autoconf macros AC_LANG_PUSH/POP is used with c++, but it is not checked if c++ is available * tweak configure_fix.patch to support this * bug 4391 was reported by ant and is fixed now * bump PR
Diffstat (limited to 'packages/speech-dispatcher')
-rw-r--r--packages/speech-dispatcher/files/configure_fix.patch30
-rw-r--r--packages/speech-dispatcher/speech-dispatcher_0.6.6.bb2
2 files changed, 20 insertions, 12 deletions
diff --git a/packages/speech-dispatcher/files/configure_fix.patch b/packages/speech-dispatcher/files/configure_fix.patch
index 19feabf379..d593d4e0ab 100644
--- a/packages/speech-dispatcher/files/configure_fix.patch
+++ b/packages/speech-dispatcher/files/configure_fix.patch
@@ -1,8 +1,16 @@
-Index: speech-dispatcher-0.6.5/configure.in
+Index: speech-dispatcher-0.6.6/configure.in
===================================================================
---- speech-dispatcher-0.6.5.orig/configure.in 2008-03-10 23:11:42.000000000 +0000
-+++ speech-dispatcher-0.6.5/configure.in 2008-03-10 23:14:02.000000000 +0000
-@@ -134,12 +134,15 @@
+--- speech-dispatcher-0.6.6.orig/configure.in 2008-07-20 13:10:44.208894676 +0200
++++ speech-dispatcher-0.6.6/configure.in 2008-07-20 13:11:16.946093820 +0200
+@@ -5,6 +5,7 @@
+
+ dnl progs
+ AC_PROG_CC
++AC_PROG_CXX
+
+ dnl info
+ AM_INIT_AUTOMAKE("speech-dispatcher", "`cat version.sh|grep '^VERSION'|awk -F= '{print $2}'`")
+@@ -134,12 +135,15 @@
AC_SUBST(ibmtts_include)
dnl check for espeak support
@@ -18,10 +26,10 @@ Index: speech-dispatcher-0.6.5/configure.in
AC_ARG_WITH(espeak, AS_HELP_STRING(--with-espeak, Compile with espeak support),
if test $withval = "no"; then
echo "Forced compilation without espeak support.";
-Index: speech-dispatcher-0.6.5/src/modules/Makefile.am
+Index: speech-dispatcher-0.6.6/src/modules/Makefile.am
===================================================================
---- speech-dispatcher-0.6.5.orig/src/modules/Makefile.am 2008-03-10 23:18:50.000000000 +0000
-+++ speech-dispatcher-0.6.5/src/modules/Makefile.am 2008-03-10 23:25:39.000000000 +0000
+--- speech-dispatcher-0.6.6.orig/src/modules/Makefile.am 2008-07-20 13:10:51.768895801 +0200
++++ speech-dispatcher-0.6.6/src/modules/Makefile.am 2008-07-20 13:10:57.665559805 +0200
@@ -8,6 +8,7 @@
EXTRA_DIST = module_main.c module_utils_addvoice.c festival_client.c festival_client.h
@@ -32,15 +40,15 @@ Index: speech-dispatcher-0.6.5/src/modules/Makefile.am
if ibmtts_support
@@ -45,6 +46,6 @@
sd_cicero_SOURCES = cicero.c module_utils.c module_utils.h
- sd_cicero_LDADD = -lm -lpthread -ldotconf @glib_libs@
+ sd_cicero_LDADD = -lpthread -ldotconf @glib_libs@ @gthread_libs@
-sd_espeak_SOURCES = espeak.c module_utils.c module_utils.h
+sd_espeak_SOURCES = espeak.c module_utils.c module_utils.h dummy.cpp
sd_espeak_LDFLAGS = -rpath '$(spdlibdir)'
- sd_espeak_LDADD = -lsdaudio -lm -lespeak -lpthread -ldotconf @SNDFILE_LIBS@ @gthread_libs@
-Index: speech-dispatcher-0.6.5/src/modules/dummy.cpp
+ sd_espeak_LDADD = -lsdaudio -lespeak -lpthread -ldotconf @glib_libs@ @SNDFILE_LIBS@ @gthread_libs@
+Index: speech-dispatcher-0.6.6/src/modules/dummy.cpp
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ speech-dispatcher-0.6.5/src/modules/dummy.cpp 2008-03-10 23:26:50.000000000 +0000
++++ speech-dispatcher-0.6.6/src/modules/dummy.cpp 2008-07-20 13:10:57.668895216 +0200
@@ -0,0 +1 @@
+
diff --git a/packages/speech-dispatcher/speech-dispatcher_0.6.6.bb b/packages/speech-dispatcher/speech-dispatcher_0.6.6.bb
index 302f642d67..105c32312f 100644
--- a/packages/speech-dispatcher/speech-dispatcher_0.6.6.bb
+++ b/packages/speech-dispatcher/speech-dispatcher_0.6.6.bb
@@ -5,7 +5,7 @@ LICENSE = "GPLv2"
DEPENDS = "espeak flite pulseaudio libdotconf glib-2.0"
RPROVIDES_${PN} += "speechd"
-PR = "r0"
+PR = "r1"
inherit autotools update-rc.d