aboutsummaryrefslogtreecommitdiffstats
path: root/packages/speech-dispatcher
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2008-01-04 14:10:09 +0000
committerMatthias Hentges <oe@hentges.net>2008-01-04 14:10:09 +0000
commitac5cd102a7b7a2a37c2c228aeb8f43ebd7d617ac (patch)
tree3ba6b95c3e3fd2d2136eec178a1456b9062ad38f /packages/speech-dispatcher
parentaa96561f14f0193cce46eb5691880fb2905f6593 (diff)
downloadopenembedded-ac5cd102a7b7a2a37c2c228aeb8f43ebd7d617ac.tar.gz
speech-dispatcher: Improve packaging
Diffstat (limited to 'packages/speech-dispatcher')
-rw-r--r--packages/speech-dispatcher/speech-dispatcher_0.6.5.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
index ac001bf1b7..68bfd8a347 100644
--- a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
+++ b/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
@@ -5,12 +5,13 @@ LICENSE = "GPLv2"
DEPENDS = "flite libdotconf glib-2.0"
RPROVIDES += "speechd"
-PR = "r0"
+PR = "r1"
inherit autotools
SRC_URI = "http://www.freebsoft.org/pub/projects/speechd/${PN}-${PV}.tar.gz \
- file://srcMakefile.am.patch;patch=1 "
+ file://srcMakefile.am.patch;patch=1 \
+ file://confSpeechd.conf_00.patch;patch=1"
LEAD_SONAME = "libspeechd.so"
@@ -18,15 +19,20 @@ do_install() {
install -d ${D}${bindir}
install -d ${D}${includedir}
install -d ${D}${libdir}/${PN}-modules
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/modules
oe_libinstall -so -C src/audio libsdaudio ${D}${libdir}
oe_libinstall -so -C src/c/api libspeechd ${D}${libdir}
install -m 0644 ${S}/src/c/api/libspeechd.h ${D}${includedir}
- install -m 0755 ${S}/src/c/clients/say/spd-say ${D}${bindir}
+ install -m 0755 ${S}/src/c/clients/say/.libs/spd-say ${D}${bindir}
install -m 0755 ${S}/src/c/clients/spdsend/spdsend ${D}${bindir}
- install -m 0755 ${S}/src/server/speech-dispatcher ${D}${bindir}
- install -m 0755 ${S}/src/modules/sd_* ${D}${libdir}/${PN}-modules/
+ install -m 0755 ${S}/src/server/.libs/speech-dispatcher ${D}${bindir}
+ install -m 0755 ${S}/src/modules/.libs/sd_* ${D}${libdir}/${PN}-modules/
+
+ install -m 0644 ${S}/config/speechd.conf ${D}${sysconfdir}
+ install -m 0644 ${S}/config/modules/*.conf ${D}${sysconfdir}/modules
}
do_stage() {