aboutsummaryrefslogtreecommitdiffstats
path: root/packages/splashutils
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-10-07 21:21:29 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-10-07 21:21:29 +0000
commitc2554365fbfa6f61c81c2ea052bb5c230364b261 (patch)
treecf877b42299907ab81aa26cb81edbe765af031a8 /packages/splashutils
parente3610d7e1cf63b11764752d4213e4879e70a4c83 (diff)
downloadopenembedded-c2554365fbfa6f61c81c2ea052bb5c230364b261.tar.gz
splashutils: firs import to openembedded
* recipe provided by Kalev Lember * closes bug 4598
Diffstat (limited to 'packages/splashutils')
-rw-r--r--packages/splashutils/.mtn2git_empty0
-rw-r--r--packages/splashutils/splashutils_1.5.4.2.bb42
2 files changed, 42 insertions, 0 deletions
diff --git a/packages/splashutils/.mtn2git_empty b/packages/splashutils/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/splashutils/.mtn2git_empty
diff --git a/packages/splashutils/splashutils_1.5.4.2.bb b/packages/splashutils/splashutils_1.5.4.2.bb
new file mode 100644
index 0000000000..36c11ab2de
--- /dev/null
+++ b/packages/splashutils/splashutils_1.5.4.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Framebuffer splash utilities."
+SECTION = "media-gfx"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://dev.gentoo.org/~spock/projects/gensplash/archive/splashutils-${PV}.tar.bz2"
+
+DEPENDS = "jpeg klibc"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+# klcc doesn't work with -isystem
+export TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}/${layout_includedir}"
+export BUILD_CPPFLAGS = "-I${STAGING_DIR_NATIVE}${layout_includedir}"
+
+do_configure_prepend() {
+ if [ -f "${S}"/src/Makefile.am ] ; then
+ sed -i "s#^INCLUDES = \(.*\)#INCLUDES = \1 $CPPFLAGS#" "${S}"/src/Makefile.am
+ fi
+}
+
+EXTRA_OECONF = "--without-gpm --without-png --without-mng --without-ttf --without-ttf-kernel"
+
+# fbcondecor_helper is also useful outside of the main package.
+RDEPENDS_${PN} = "${PN}-helper"
+
+PACKAGES =+ "${PN}-helper"
+FILES_${PN}-helper = "${base_sbindir}/fbcondecor_helper ${base_sbindir}/splash_helper"
+FILES_${PN} += "/lib"
+
+do_install_append () {
+ if [ -f "${S}"/debian/splashutils.dirs ] ; then
+ for dir in $(cat debian/splashutils.dirs) ; do
+ mkdir -p ${D}/$dir
+ done
+ fi
+
+ ln -s fbcondecor_helper ${D}${base_sbindir}/splash_helper
+
+}