aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sqlite
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2005-02-04 00:58:07 +0000
committerChris Larson <clarson@kergoth.com>2005-02-04 00:58:07 +0000
commitaa6e7f0a8f90f91abb358db08466bf8d7e9bff9e (patch)
tree27e9e01a7a21ee20654a5d6f7e7cb4436da8eacb /packages/sqlite
parent3f48dde2fbacd5116b65cc9838f7594b5295d779 (diff)
downloadopenembedded-aa6e7f0a8f90f91abb358db08466bf8d7e9bff9e.tar.gz
Merge oe-devel@oe-devel.bkbits.net:openembedded
into handhelds.org:/home/kergoth/code/openembedded 2005/02/03 19:57:50-05:00 handhelds.org!kergoth sqlite3: kill the ugly EXTRA_OEMAKE hacks in favor of patching the buildsystem to suck slightly less. Fix the packaging to be cleaner. Rename the sqlite3-bin package to just 'sqlite3'. Enable 'threadsafe' mode. BKrev: 4202c89fZ982701lXAgEknqxwxEOEw
Diffstat (limited to 'packages/sqlite')
-rw-r--r--packages/sqlite/sqlite3-3.0.8/ldflags.patch0
-rw-r--r--packages/sqlite/sqlite3-3.0.8/libtool.patch0
-rw-r--r--packages/sqlite/sqlite3_3.0.8.bb29
3 files changed, 18 insertions, 11 deletions
diff --git a/packages/sqlite/sqlite3-3.0.8/ldflags.patch b/packages/sqlite/sqlite3-3.0.8/ldflags.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/sqlite/sqlite3-3.0.8/ldflags.patch
diff --git a/packages/sqlite/sqlite3-3.0.8/libtool.patch b/packages/sqlite/sqlite3-3.0.8/libtool.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/sqlite/sqlite3-3.0.8/libtool.patch
diff --git a/packages/sqlite/sqlite3_3.0.8.bb b/packages/sqlite/sqlite3_3.0.8.bb
index f0abd6edad..a50472130d 100644
--- a/packages/sqlite/sqlite3_3.0.8.bb
+++ b/packages/sqlite/sqlite3_3.0.8.bb
@@ -3,32 +3,39 @@ SECTION = "libs"
PRIORITY = "optional"
DEPENDS = "readline ncurses"
LICENSE = "PD"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.sqlite.org/sqlite-3.0.8.tar.gz \
- file://cross-compile.patch;patch=1 "
+ file://cross-compile.patch;patch=1 \
+ file://libtool.patch;patch=1 \
+ file://ldflags.patch;patch=1"
S = "${WORKDIR}/sqlite"
inherit autotools
-EXTRA_OECONF = "--without-tcl --disable-static --enable-shared"
-EXTRA_OEMAKE = "'LIBREADLINE=-L${STAGING_LIBDIR} -lreadline -lncurses' LIBTOOL='./${TARGET_ARCH}-${TARGET_OS}-libtool' "
+EXTRA_OECONF = "--without-tcl --enable-shared \
+ --enable-threadsafe"
export config_BUILD_CC = "${BUILD_CC}"
export config_BUILD_CFLAGS = "${BUILD_CFLAGS}"
+export config_BUILD_LIBS = "${BUILD_LDFLAGS}"
export config_TARGET_CC = "${CC}"
export config_TARGET_LINK = "${CCLD}"
export config_TARGET_CFLAGS = "${CFLAGS}"
-
+export config_TARGET_LFLAGS = "${LDFLAGS}"
do_stage() {
oe_libinstall -so libsqlite3 ${STAGING_LIBDIR}
install -m 0644 sqlite3.h ${STAGING_INCDIR}
}
-do_install() {
- oe_runmake install DESTDIR=${D} prefix=${prefix} exec_prefix=${exec_prefix}
-}
+#do_install() {
+# oe_runmake install DESTDIR=${D} prefix=${prefix} exec_prefix=${exec_prefix}
+#}
-PACKAGES = "libsqlite sqlite3-bin"
-FILES_sqlite3-bin = "${bindir}/*"
-FILES_libsqlite = "${libdir}/*"
+PACKAGES = "libsqlite libsqlite-dev libsqlite-doc sqlite3"
+FILES_sqlite3 = "${bindir}/*"
+FILES_libsqlite = "${libdir}/*.so.*"
+FILES_libsqlite-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so \
+ ${libdir}/pkgconfig ${includedir}"
+FILES_libsqlite-doc = "${datadir}/doc ${mandir} ${infodir}"
+AUTO_LIBNAME_PKGS = "libsqlite"