aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sqlite
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-09-29 10:45:59 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-29 10:45:59 +0000
commitb94028a629b0d80eabe408ae599f776379cbc77a (patch)
tree1579296af2a786ece46bbc1f783dfe3fe26f3ce6 /packages/sqlite
parent75a027fb69828b13cf74d6a0fbac7efcf8375861 (diff)
downloadopenembedded-b94028a629b0d80eabe408ae599f776379cbc77a.tar.gz
sqlite3: added 3.2.7 version
Diffstat (limited to 'packages/sqlite')
-rw-r--r--packages/sqlite/sqlite3-3.2.7/.mtn2git_empty0
-rw-r--r--packages/sqlite/sqlite3-3.2.7/cross-compile.patch84
-rw-r--r--packages/sqlite/sqlite3-3.2.7/ldflags.patch77
-rw-r--r--packages/sqlite/sqlite3-3.2.7/libtool.patch25
-rw-r--r--packages/sqlite/sqlite3_3.2.7.bb44
5 files changed, 230 insertions, 0 deletions
diff --git a/packages/sqlite/sqlite3-3.2.7/.mtn2git_empty b/packages/sqlite/sqlite3-3.2.7/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/sqlite/sqlite3-3.2.7/.mtn2git_empty
diff --git a/packages/sqlite/sqlite3-3.2.7/cross-compile.patch b/packages/sqlite/sqlite3-3.2.7/cross-compile.patch
new file mode 100644
index 0000000000..aaafaa590c
--- /dev/null
+++ b/packages/sqlite/sqlite3-3.2.7/cross-compile.patch
@@ -0,0 +1,84 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+Index: sqlite-3.2.1/configure.ac
+===================================================================
+--- sqlite-3.2.1.orig/configure.ac 2005-03-23 17:08:39.000000000 +0100
++++ sqlite-3.2.1/configure.ac 2005-04-25 23:02:40.000000000 +0200
+@@ -186,10 +186,11 @@
+ default_build_cflags="-g"
+ if test "$config_BUILD_CC" = ""; then
+ AC_PROG_CC
+- if test "$cross_compiling" = "yes"; then
+- AC_MSG_ERROR([unable to find a compiler for building build tools])
+- fi
+- BUILD_CC=$CC
++# if test "$cross_compiling" = "yes"; then
++# AC_MSG_ERROR([unable to find a compiler for building build tools])
++# fi
++# BUILD_CC=$CC
++ BUILD_CC=gcc
+ default_build_cflags=$CFLAGS
+ else
+ BUILD_CC=$config_BUILD_CC
+@@ -539,55 +540,14 @@
+ # Figure out what C libraries are required to compile programs
+ # that use "readline()" library.
+ #
+-if test "$config_TARGET_READLINE_LIBS" != ""; then
+- TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
+-else
+- CC=$TARGET_CC
+- LIBS=""
+- AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
+- AC_CHECK_LIB([readline], [readline])
+- TARGET_READLINE_LIBS="$LIBS"
+-fi
++TARGET_READLINE_LIBS="-lreadline"
+ AC_SUBST(TARGET_READLINE_LIBS)
+
+ ##########
+ # Figure out where to get the READLINE header files.
+ #
+-AC_MSG_CHECKING([readline header files])
+-found=no
+-if test "$config_TARGET_READLINE_INC" != ""; then
+- TARGET_READLINE_INC=$config_TARGET_READLINE_INC
+- found=yes
+-fi
+-if test "$found" = "yes"; then
+- AC_MSG_RESULT($TARGET_READLINE_INC)
+-else
+- AC_MSG_RESULT(not specified: still searching...)
+- AC_CHECK_HEADER(readline.h, [found=yes])
+-fi
+-if test "$found" = "no"; then
+- for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
+- AC_CHECK_FILE($dir/include/readline.h, found=yes)
+- if test "$found" = "yes"; then
+- TARGET_READLINE_INC="-I$dir/include"
+- break
+- fi
+- AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
+- if test "$found" = "yes"; then
+- TARGET_READLINE_INC="-I$dir/include/readline"
+- break
+- fi
+- done
+-fi
+-if test "$found" = "yes"; then
+- if test "$TARGET_READLINE_LIBS" = ""; then
+- TARGET_HAVE_READLINE=0
+- else
+- TARGET_HAVE_READLINE=1
+- fi
+-else
+- TARGET_HAVE_READLINE=0
+-fi
++TARGET_READLINE_INC=""
++TARGET_HAVE_READLINE=1
+ AC_SUBST(TARGET_READLINE_INC)
+ AC_SUBST(TARGET_HAVE_READLINE)
+
diff --git a/packages/sqlite/sqlite3-3.2.7/ldflags.patch b/packages/sqlite/sqlite3-3.2.7/ldflags.patch
new file mode 100644
index 0000000000..7f40385f25
--- /dev/null
+++ b/packages/sqlite/sqlite3-3.2.7/ldflags.patch
@@ -0,0 +1,77 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- sqlite-3.2.5/Makefile.in~ldflags
++++ sqlite-3.2.5/Makefile.in
+@@ -31,6 +31,10 @@
+ #
+ TCC = @TARGET_CC@ @TARGET_CFLAGS@ -I. -I${TOP}/src
+
++# OE overrides
++#
++TARGET_LFLAGS = @TARGET_LFLAGS@
++
+ # Define -DNDEBUG to compile without debugging (i.e., for production usage)
+ # Omitting the define will cause extra debugging code to be inserted and
+ # includes extra comments when "EXPLAIN stmt" is used.
+@@ -235,17 +239,17 @@
+ | awk '{print $$5,$$6}' >last_change
+
+ libsqlite3.la: $(LIBOBJ)
+- $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(LIBPTHREAD) \
++ $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(TARGET_LFLAGS) $(LIBPTHREAD) \
+ ${ALLOWRELEASE} -rpath $(libdir) -version-info "8:6:8"
+
+ libtclsqlite3.la: tclsqlite.lo libsqlite3.la
+ $(LTLINK) -o libtclsqlite3.la tclsqlite.lo \
+- $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(LIBPTHREAD) \
++ $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(TARGET_LFLAGS) $(LIBPTHREAD) \
+ -rpath $(libdir)/sqlite \
+ -version-info "8:6:8"
+
+ sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
+- $(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \
++ $(LTLINK) $(TARGET_LFLAGS) $(READLINE_FLAGS) $(LIBPTHREAD) \
+ -o sqlite3 $(TOP)/src/shell.c libsqlite3.la $(LIBREADLINE)
+
+ # This target creates a directory named "tsrc" and fills it with
+@@ -419,18 +423,18 @@
+
+ tclsqlite3: tclsqlite-shell.lo libsqlite3.la
+ $(LTLINK) -o tclsqlite3 tclsqlite-shell.lo \
+- libsqlite3.la $(LIBTCL)
++ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
+
+ testfixture$(TEXE): $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC)
+ $(LTLINK) -DTCLSH=1 -DSQLITE_TEST=1 $(TEMP_STORE) \
+ -o testfixture $(TESTSRC) $(TOP)/src/tclsqlite.c \
+- libsqlite3.la $(LIBTCL)
++ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
+
+ crashtest$(TEXE): $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC) $(TOP)/src/os_test.c
+ $(LTLINK) -DOS_TEST=1 -DTCLSH=1 -DSQLITE_TEST=1 \
+ -o crashtest \
+ $(TESTSRC) $(TOP)/src/os_test.c $(TOP)/src/tclsqlite.c \
+- libsqlite3.la $(LIBTCL)
++ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
+
+
+
+--- sqlite-3.2.5/configure.ac~ldflags
++++ sqlite-3.2.5/configure.ac
+@@ -238,6 +238,13 @@
+ TARGET_LINK=$config_TARGET_LINK
+ fi
+ AC_MSG_RESULT($TARGET_LINK)
++AC_MSG_CHECKING([switches on the target linker])
++if test "$config_TARGET_LFLAGS" != ""; then
++ TARGET_LFLAGS=$config_TARGET_LFLAGS
++else
++ TARGET_LFLAGS=$BUILD_LFLAGS
++fi
++AC_MSG_RESULT($TARGET_LFLAGS)
+ AC_MSG_CHECKING([switches on the target compiler])
+ if test "$config_TARGET_TFLAGS" != ""; then
+ TARGET_TFLAGS=$config_TARGET_TFLAGS
diff --git a/packages/sqlite/sqlite3-3.2.7/libtool.patch b/packages/sqlite/sqlite3-3.2.7/libtool.patch
new file mode 100644
index 0000000000..ccf9993ed2
--- /dev/null
+++ b/packages/sqlite/sqlite3-3.2.7/libtool.patch
@@ -0,0 +1,25 @@
+Index: sqlite-3.2.1/Makefile.in
+===================================================================
+--- sqlite-3.2.1.orig/Makefile.in 2005-03-23 17:09:39.000000000 +0100
++++ sqlite-3.2.1/Makefile.in 2005-04-25 23:11:20.000000000 +0200
+@@ -15,7 +15,10 @@
+ # The toplevel directory of the source tree. This is the directory
+ # that contains this "Makefile.in" and the "configure.in" script.
+ #
+-TOP = @srcdir@
++TOP = $(srcdir)
++srcdir = @srcdir@
++top_srcdir = @top_srcdir@
++top_builddir = .
+
+ # C Compiler and options for use in building executables that
+ # will run on the platform that is doing the build.
+@@ -96,7 +99,7 @@
+ exec_prefix = @exec_prefix@
+ libdir = @libdir@
+ INSTALL = @INSTALL@
+-LIBTOOL = ./libtool
++LIBTOOL = @LIBTOOL@
+ ALLOWRELEASE = @ALLOWRELEASE@
+
+ # libtool compile/link/install
diff --git a/packages/sqlite/sqlite3_3.2.7.bb b/packages/sqlite/sqlite3_3.2.7.bb
new file mode 100644
index 0000000000..a133f832a9
--- /dev/null
+++ b/packages/sqlite/sqlite3_3.2.7.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "An Embeddable SQL Database Engine"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "readline ncurses"
+LICENSE = "PD"
+
+SRC_URI = "http://www.sqlite.org/sqlite-${PV}.tar.gz \
+ file://cross-compile.patch;patch=1 \
+ file://libtool.patch;patch=1 \
+ file://ldflags.patch;patch=1"
+S = "${WORKDIR}/sqlite-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-tcl --enable-shared \
+ --enable-threadsafe"
+export config_BUILD_CC = "${BUILD_CC}"
+export config_BUILD_CFLAGS = "${BUILD_CFLAGS}"
+export config_BUILD_LIBS = "${BUILD_LDFLAGS}"
+export config_TARGET_CC = "${CC}"
+export config_TARGET_LINK = "${CCLD}"
+export config_TARGET_CFLAGS = "${CFLAGS}"
+export config_TARGET_LFLAGS = "${LDFLAGS}"
+
+do_compile_prepend() {
+ oe_runmake sqlite3.h
+ install -m 0644 sqlite3.h ${STAGING_INCDIR}
+}
+
+do_stage() {
+ oe_libinstall -so libsqlite3 ${STAGING_LIBDIR}
+}
+
+#do_install() {
+# oe_runmake install DESTDIR=${D} prefix=${prefix} exec_prefix=${exec_prefix}
+#}
+
+PACKAGES = "libsqlite libsqlite-dev libsqlite-doc sqlite3"
+FILES_sqlite3 = "${bindir}/*"
+FILES_libsqlite = "${libdir}/*.so.*"
+FILES_libsqlite-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so \
+ ${libdir}/pkgconfig ${includedir}"
+FILES_libsqlite-doc = "${docdir} ${mandir} ${infodir}"
+AUTO_LIBNAME_PKGS = "libsqlite"