aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sqlite
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/sqlite
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/sqlite')
-rw-r--r--packages/sqlite/sqlite_2.8.15.bb56
-rw-r--r--packages/sqlite/sqlite_2.8.9.bb39
2 files changed, 95 insertions, 0 deletions
diff --git a/packages/sqlite/sqlite_2.8.15.bb b/packages/sqlite/sqlite_2.8.15.bb
index e69de29bb2..17b3605f12 100644
--- a/packages/sqlite/sqlite_2.8.15.bb
+++ b/packages/sqlite/sqlite_2.8.15.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "An Embeddable SQL Database Engine"
+HOMEPAGE = "http://www.sqlite.org/"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "readline ncurses"
+LICENSE = "PD"
+PR = "r3"
+
+SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \
+ file://main.mk"
+S = "${WORKDIR}/sqlite"
+
+SOURCES = "attach.o auth.o btree.o btree_rb.o build.o copy.o date.o delete.o expr.o func.o hash.o \
+ insert.o main.o opcodes.o os.o pager.o parse.o pragma.o printf.o random.o select.o table.o \
+ tokenize.o trigger.o update.o util.o vacuum.o vdbe.o vdbeaux.o where.o"
+
+inherit autotools
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/main.mk ${S}/
+}
+
+do_compile() {
+ oe_runmake -f Makefile.linux-gcc \
+ TOP="${S}" \
+ BCC="${BUILD_CC}" \
+ TCC="${CC}" \
+ OPTS="-fPIC" \
+ TCL_FLAGS= LIBTCL= \
+ READLINE_FLAGS="-DHAVE_READLINE=1 -I${STAGING_INCDIR}" \
+ LIBREADLINE="-L. -L${STAGING_LIBDIR} -lreadline -lncurses"
+}
+
+do_stage() {
+ install -m 0755 libsqlite.so ${STAGING_LIBDIR}/libsqlite.so.0.8.6
+ ln -sf libsqlite.so.0.8.6 ${STAGING_LIBDIR}/libsqlite.so
+ ln -sf libsqlite.so.0.8.6 ${STAGING_LIBDIR}/libsqlite.so.0
+ ln -sf libsqlite.so.0.8.6 ${STAGING_LIBDIR}/libsqlite.so.0.8
+ install -m 0644 sqlite.h ${STAGING_INCDIR}
+}
+
+do_install() {
+ install -d ${D}${libdir} ${D}${bindir}
+ install sqlite ${D}${bindir}
+ install -m 0755 libsqlite.so ${D}${libdir}/libsqlite.so.0.8.6
+ ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so
+ ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0
+ ln -sf libsqlite.so.0.8.6 ${D}${libdir}/libsqlite.so.0.8
+ install -d ${D}${includedir}
+ install -m 0644 sqlite.h ${D}${includedir}/sqlite.h
+}
+
+PACKAGES += "${PN}-bin"
+FILES_${PN}-bin = "${bindir}"
+FILES_${PN} = "${libdir}/*.so.*"
+
diff --git a/packages/sqlite/sqlite_2.8.9.bb b/packages/sqlite/sqlite_2.8.9.bb
index e69de29bb2..5063711928 100644
--- a/packages/sqlite/sqlite_2.8.9.bb
+++ b/packages/sqlite/sqlite_2.8.9.bb
@@ -0,0 +1,39 @@
+PR = "r1"
+DESCRIPTION = "An Embeddable SQL Database Engine"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "readline ncurses"
+LICENSE = "PD"
+
+PACKAGES =+ "sqlite-bin"
+
+FILES_sqlite-bin = "${bindir}"
+
+SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \
+ file://crosscompile.patch;patch=1"
+
+S = "${WORKDIR}/sqlite"
+
+inherit autotools
+
+EXTRA_OECONF = "--without-tcl --enable-static --enable-shared"
+EXTRA_OEMAKE = "'LIBREADLINE=-L${STAGING_LIBDIR} -lreadline -lncurses' 'LIBTOOL=${S}/${HOST_PREFIX}libtool'"
+export config_BUILD_CC = "${BUILD_CC}"
+export config_BUILD_CFLAGS = "${BUILD_CFLAGS}"
+export config_TARGET_CC = "${CC}"
+export config_TARGET_LINK = "${CCLD}"
+export config_TARGET_CFLAGS = "${CFLAGS}"
+
+do_compile () {
+ oe_runmake
+}
+
+do_stage() {
+ oe_libinstall -so libsqlite ${STAGING_LIBDIR}
+ install -m 0644 sqlite.h ${STAGING_INCDIR}
+}
+
+do_install() {
+ oe_runmake install prefix=${D}${prefix} exec_prefix=${D}${exec_prefix}
+}
+