aboutsummaryrefslogtreecommitdiffstats
path: root/packages/squashfs-tools
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-11-16 19:50:10 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-11-16 19:50:10 +0000
commit0048e583c9234dfc488609fb501c301b3d61da39 (patch)
tree71d882c578c0ce20fbea0ddd0b64374ef2aee6e8 /packages/squashfs-tools
parent6eb50a468d6bba9421c55a8ac102d58b56804b5b (diff)
downloadopenembedded-0048e583c9234dfc488609fb501c301b3d61da39.tar.gz
squashfs-tools: Added release 3.3.
Diffstat (limited to 'packages/squashfs-tools')
-rw-r--r--packages/squashfs-tools/squashfs-tools-3.3/.mtn2git_empty0
-rw-r--r--packages/squashfs-tools/squashfs-tools-3.3/Makefile.patch32
-rw-r--r--packages/squashfs-tools/squashfs-tools-native_3.3.bb10
-rw-r--r--packages/squashfs-tools/squashfs-tools.inc19
-rw-r--r--packages/squashfs-tools/squashfs-tools_3.3.bb7
5 files changed, 68 insertions, 0 deletions
diff --git a/packages/squashfs-tools/squashfs-tools-3.3/.mtn2git_empty b/packages/squashfs-tools/squashfs-tools-3.3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/squashfs-tools/squashfs-tools-3.3/.mtn2git_empty
diff --git a/packages/squashfs-tools/squashfs-tools-3.3/Makefile.patch b/packages/squashfs-tools/squashfs-tools-3.3/Makefile.patch
new file mode 100644
index 0000000000..5addf8dd34
--- /dev/null
+++ b/packages/squashfs-tools/squashfs-tools-3.3/Makefile.patch
@@ -0,0 +1,32 @@
+Index: squashfs-tools/Makefile
+===================================================================
+--- squashfs-tools.orig/Makefile 2007-11-16 20:32:00.000000000 +0100
++++ squashfs-tools/Makefile 2007-11-16 20:37:04.000000000 +0100
+@@ -1,19 +1,24 @@
+ INCLUDEDIR = .
+
+-CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE -O2
++LOCAL_CFLAGS := -I$(INCLUDEDIR) -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_GNU_SOURCE
+
+ all: mksquashfs unsquashfs
+
+ mksquashfs: mksquashfs.o read_fs.o sort.o
+- $(CC) mksquashfs.o read_fs.o sort.o -lz -lpthread -lm -o $@
++ $(CC) $(LDFLAGS) mksquashfs.o read_fs.o sort.o -lz -lpthread -lm -o $@
+
+ mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
++ $(CC) $(CFLAGS) $(LOCAL_CFLAGS) -c -o mksquashfs.o mksquashfs.c
+
+ read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h
++ $(CC) $(CFLAGS) $(LOCAL_CFLAGS) -c -o read_fs.o read_fs.c
+
+ sort.o: sort.c squashfs_fs.h global.h sort.h
++ $(CC) $(CFLAGS) $(LOCAL_CFLAGS) -c -o sort.o sort.c
+
+ unsquashfs: unsquashfs.o
+- $(CC) unsquashfs.o -lz -o $@
++ $(CC) $(LDFLAGS) unsquashfs.o -lz -o $@
+
+ unsquashfs.o: unsquashfs.c squashfs_fs.h read_fs.h global.h
++ $(CC) $(CFLAGS) $(LOCAL_CFLAGS) -c -o unsquashfs.o -lz -o $@
++
diff --git a/packages/squashfs-tools/squashfs-tools-native_3.3.bb b/packages/squashfs-tools/squashfs-tools-native_3.3.bb
new file mode 100644
index 0000000000..c35d183a08
--- /dev/null
+++ b/packages/squashfs-tools/squashfs-tools-native_3.3.bb
@@ -0,0 +1,10 @@
+require squashfs-tools_${PV}.bb
+
+inherit native
+
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/squashfs-tools-${PV}', '${FILE_DIRNAME}/squashfs-tools', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
+PACKAGES = ""
+
+do_stage () {
+ install -m 0755 mksquashfs ${STAGING_BINDIR}/
+}
diff --git a/packages/squashfs-tools/squashfs-tools.inc b/packages/squashfs-tools/squashfs-tools.inc
new file mode 100644
index 0000000000..2083bd171d
--- /dev/null
+++ b/packages/squashfs-tools/squashfs-tools.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Squashfs is a highly compressed read-only filesystem for Linux."
+SECTION = "base"
+LICENSE = "GPLv2"
+PR = "r0"
+
+DEPENDS = "zlib"
+
+S = "${WORKDIR}/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}/squashfs-tools"
+
+prefix = ""
+
+do_compile() {
+ oe_runmake mksquashfs
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ install -m 0755 mksquashfs ${D}${sbindir}/
+}
diff --git a/packages/squashfs-tools/squashfs-tools_3.3.bb b/packages/squashfs-tools/squashfs-tools_3.3.bb
new file mode 100644
index 0000000000..819a45606a
--- /dev/null
+++ b/packages/squashfs-tools/squashfs-tools_3.3.bb
@@ -0,0 +1,7 @@
+require squashfs-tools.inc
+
+# some release have .tgz, some have .tar.gz, so keep that outside the .inc file
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${@bb.data.getVar('PV',d,1).replace('r','-r')}.tgz \
+file://Makefile.patch;patch=1"
+