aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ssmtp
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 07:40:09 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-31 07:40:09 +0000
commit7d6006735f2de129c026f9ff3d55f854591124df (patch)
tree3d220c42a2367e6730a3ea24bacf919aa4991bfc /packages/ssmtp
parent49275ccd3ebfa3ae13b2a6b49402c09cd88cc719 (diff)
downloadopenembedded-7d6006735f2de129c026f9ff3d55f854591124df.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/30 23:33:57-08:00 (none)!ggilbert Adding licenses BKrev: 41d50259A1gWI8c_Qj68LM4jway6jw
Diffstat (limited to 'packages/ssmtp')
-rw-r--r--packages/ssmtp/ssmtp_2.60.9.bb24
-rw-r--r--packages/ssmtp/ssmtp_2.61.bb24
2 files changed, 48 insertions, 0 deletions
diff --git a/packages/ssmtp/ssmtp_2.60.9.bb b/packages/ssmtp/ssmtp_2.60.9.bb
index e69de29bb2..8da46eafe5 100644
--- a/packages/ssmtp/ssmtp_2.60.9.bb
+++ b/packages/ssmtp/ssmtp_2.60.9.bb
@@ -0,0 +1,24 @@
+SECTION = "console/network"
+DEPENDS = "openssl"
+DESCRIPTION = "Extremely simple MTA to get mail off the system to a mail hub."
+LICENSE = "GPL"
+SRC_URI = "${DEBIAN_MIRROR}/main/s/ssmtp/ssmtp_${PV}.tar.gz \
+ file://ldflags.patch;patch=1 \
+ file://configure.patch;patch=1 \
+ file://ssmtp.conf"
+S = "${WORKDIR}/${PN}-2.60"
+
+inherit autotools
+
+EXTRA_OECONF = "--enable-ssl"
+do_compile () {
+ oe_runmake 'LDFLAGS=${LDFLAGS}'
+}
+
+do_install () {
+ oe_runmake 'prefix=${D}/${prefix}' 'exec_prefix=${D}/${exec_prefix}' \
+ 'bindir=${D}/${bindir}' 'mandir=${D}/${mandir}' \
+ 'etcdir=${D}/${sysconfdir}' GEN_CONFIG="`which echo`" install
+ install -d ${D}/${sysconfdir}/ssmtp
+ install -m 0644 ${WORKDIR}/ssmtp.conf ${D}/${sysconfdir}/ssmtp/ssmtp.conf
+}
diff --git a/packages/ssmtp/ssmtp_2.61.bb b/packages/ssmtp/ssmtp_2.61.bb
index e69de29bb2..193412d9fc 100644
--- a/packages/ssmtp/ssmtp_2.61.bb
+++ b/packages/ssmtp/ssmtp_2.61.bb
@@ -0,0 +1,24 @@
+SECTION = "console/network"
+DEPENDS = "openssl"
+DESCRIPTION = "Extremely simple MTA to get mail off the system to a mail hub."
+
+SRC_URI = "${DEBIAN_MIRROR}/main/s/ssmtp/ssmtp_${PV}.orig.tar.gz \
+ file://ldflags.patch;patch=1 \
+ file://configure.patch;patch=1 \
+ file://ssmtp.conf"
+S = "${WORKDIR}/${PN}-2.61"
+LICENSE = "GPL"
+inherit autotools
+
+EXTRA_OECONF = "--enable-ssl"
+do_compile () {
+ oe_runmake 'LDFLAGS=${LDFLAGS}'
+}
+
+do_install () {
+ oe_runmake 'prefix=${D}/${prefix}' 'exec_prefix=${D}/${exec_prefix}' \
+ 'bindir=${D}/${bindir}' 'mandir=${D}/${mandir}' \
+ 'etcdir=${D}/${sysconfdir}' GEN_CONFIG="`which echo`" install
+ install -d ${D}/${sysconfdir}/ssmtp
+ install -m 0644 ${WORKDIR}/ssmtp.conf ${D}/${sysconfdir}/ssmtp/ssmtp.conf
+}