aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ssmtp
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-08-09 22:36:30 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-09 22:36:30 +0000
commitb220c19aad08172bc787389040701c23ce632511 (patch)
treeaa59852a4a072be8b4db77384fb02b194f5a46c2 /packages/ssmtp
parentbf74c6866a479a57b4c6c558bc7da42a58ea8d28 (diff)
downloadopenembedded-b220c19aad08172bc787389040701c23ce632511.tar.gz
Add symlink to sendmail
Diffstat (limited to 'packages/ssmtp')
-rw-r--r--packages/ssmtp/ssmtp_2.61.bb12
1 files changed, 11 insertions, 1 deletions
diff --git a/packages/ssmtp/ssmtp_2.61.bb b/packages/ssmtp/ssmtp_2.61.bb
index f61781ff4e..680729bca3 100644
--- a/packages/ssmtp/ssmtp_2.61.bb
+++ b/packages/ssmtp/ssmtp_2.61.bb
@@ -1,7 +1,8 @@
SECTION = "console/network"
+
DEPENDS = "openssl"
DESCRIPTION = "Extremely simple MTA to get mail off the system to a mail hub."
-PR = "r1"
+PR = "r2"
SRC_URI = "${DEBIAN_MIRROR}/main/s/ssmtp/ssmtp_${PV}.orig.tar.gz \
file://ldflags.patch;patch=1 \
@@ -10,6 +11,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/s/ssmtp/ssmtp_${PV}.orig.tar.gz \
file://ssmtp.conf"
S = "${WORKDIR}/${PN}-2.61"
LICENSE = "GPL"
+CONFFILE = "${sysconfdir}/ssmtp/ssmtp.conf"
inherit autotools
EXTRA_OECONF = "--enable-ssl"
@@ -24,3 +26,11 @@ do_install () {
install -d ${D}${sysconfdir}/ssmtp
install -m 0644 ${WORKDIR}/ssmtp.conf ${D}${sysconfdir}/ssmtp/ssmtp.conf
}
+
+pkg_postinst () {
+ update-alternatives --install ${sbindir}/sendmail sendmail ${bindir}/ssmtp
+}
+
+pkg_postrm () {
+ update-alternatives --remove ${sbindir}/sendmail sendmail
+}