aboutsummaryrefslogtreecommitdiffstats
path: root/packages/stage-manager
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-17 08:30:22 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-17 08:30:22 +0000
commit0e3a4597c74d4d9b8be6c67cc5c409ccbea2ca88 (patch)
tree26823f5d5aa1caaea6435ef75764bd40720e0d0c /packages/stage-manager
parentad1a2216f7b1bcccfdf6844c32a5e2e0b50cc572 (diff)
downloadopenembedded-0e3a4597c74d4d9b8be6c67cc5c409ccbea2ca88.tar.gz
packaged-staging: add a recipe for stage-manager and DEPENDS on it
Diffstat (limited to 'packages/stage-manager')
-rw-r--r--packages/stage-manager/.mtn2git_empty0
-rw-r--r--packages/stage-manager/files/.mtn2git_empty0
-rwxr-xr-xpackages/stage-manager/files/stage-manager110
-rw-r--r--packages/stage-manager/stagemanager-native_0.0.bb12
4 files changed, 122 insertions, 0 deletions
diff --git a/packages/stage-manager/.mtn2git_empty b/packages/stage-manager/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/stage-manager/.mtn2git_empty
diff --git a/packages/stage-manager/files/.mtn2git_empty b/packages/stage-manager/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/stage-manager/files/.mtn2git_empty
diff --git a/packages/stage-manager/files/stage-manager b/packages/stage-manager/files/stage-manager
new file mode 100755
index 0000000000..3fed475906
--- /dev/null
+++ b/packages/stage-manager/files/stage-manager
@@ -0,0 +1,110 @@
+#!/usr/bin/env python
+
+import optparse
+import os, sys, stat
+
+__version__ = "0.0.1"
+
+
+def write_cache(cachefile, cachedata):
+ fd = open(cachefile, 'w')
+ for f in cachedata:
+ s = f + '|' + str(cachedata[f]['ts']) + '|' + str(cachedata[f]['size'])
+ fd.write(s + '\n')
+ fd.close()
+
+def read_cache(cachefile):
+ cache = {}
+ f = open(cachefile, 'r')
+ lines = f.readlines()
+ f.close()
+ for l in lines:
+ data = l.split('|')
+ cache[data[0]] = {}
+ cache[data[0]]['ts'] = int(data[1])
+ cache[data[0]]['size'] = int(data[2])
+ return cache
+
+def mkdirhier(dir):
+ """Create a directory like 'mkdir -p', but does not complain if
+ directory already exists like os.makedirs
+ """
+ try:
+ os.makedirs(dir)
+ except OSError, e:
+ if e.errno != 17: raise e
+
+if __name__ == "__main__":
+ parser = optparse.OptionParser( version = "Metadata Stage Manager version %s" % ( __version__ ),
+ usage = """%prog [options]\n\nPerforms mamagement tasks on a metadata staging area.""" )
+
+ parser.add_option( "-p", "--parentdir", help = "the path to the metadata parent directory",
+ action = "store", dest = "parentdir", default = None)
+
+ parser.add_option( "-c", "--cachefile", help = "the cache file to use",
+ action = "store", dest = "cachefile", default = None)
+
+ parser.add_option( "-d", "--copydir", help = "copy changed files to this directory",
+ action = "store", dest = "copydir", default = None)
+
+ parser.add_option( "-u", "--update", help = "update the cache file",
+ action = "store_true", dest = "update", default = False)
+
+ (options, args) = parser.parse_args()
+
+ if options.parentdir is None:
+ print("Error, --parentdir option not supplied")
+ sys.exit(1)
+
+ if options.cachefile is None:
+ print("Error, --cachefile option not supplied")
+ sys.exit(1)
+
+ if not options.parentdir.endswith('/'):
+ options.parentdir = options.parentdir + '/'
+
+ cache = {}
+ if os.access(options.cachefile, os.F_OK):
+ cache = read_cache(options.cachefile)
+
+ found = False
+
+ for root, dirs, files in os.walk(options.parentdir):
+ for f in files:
+ path = os.path.join(root, f)
+ if not os.access(path, os.R_OK):
+ continue
+ fstamp = os.stat(path)
+ if path not in cache:
+ print "new file %s" % path
+ cache[path] = {}
+ cache[path]['ts'] = fstamp[stat.ST_MTIME]
+ cache[path]['size'] = fstamp[stat.ST_SIZE]
+ if options.copydir:
+ copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
+ mkdirhier(os.path.split(copypath)[0])
+ os.system("mv " + path + " " + copypath)
+ found = True
+ else:
+ if cache[path]['ts'] != fstamp[stat.ST_MTIME] or cache[path]['size'] != fstamp[stat.ST_SIZE]:
+ print "file %s changed" % path
+ cache[path] = {}
+ cache[path]['ts'] = fstamp[stat.ST_MTIME]
+ cache[path]['size'] = fstamp[stat.ST_SIZE]
+ if options.copydir:
+ copypath = os.path.join(options.copydir, path.replace(options.parentdir, '', 1))
+ mkdirhier(os.path.split(copypath)[0])
+ os.system("mv " + path + " " + copypath)
+ found = True
+
+ if options.update:
+ print "Updating"
+ mkdirhier(os.path.split(options.cachefile)[0])
+ write_cache(options.cachefile, cache)
+
+ if found:
+ sys.exit(5)
+ sys.exit(0)
+
+
+
diff --git a/packages/stage-manager/stagemanager-native_0.0.bb b/packages/stage-manager/stagemanager-native_0.0.bb
new file mode 100644
index 0000000000..bc0efd50a1
--- /dev/null
+++ b/packages/stage-manager/stagemanager-native_0.0.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Helper script for packaged-staging.bbclass"
+
+SRC_URI = "file://stage-manager"
+
+INHIBIT_DEFAULT_DEPS = "1"
+
+do_install() {
+ install -d ${STAGING_BINDIR}
+ install -m 0755 ${WORKDIR}/stage-manager ${STAGING_BINDIR}
+}
+
+