aboutsummaryrefslogtreecommitdiffstats
path: root/packages/strace
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-05-17 16:32:10 +0000
committerHolger Freyther <zecke@selfish.org>2007-05-17 16:32:10 +0000
commitb0fdd5d38e3b9643df309243d62c8ffde88d141f (patch)
tree4f9f79c9fed04d90e97bb383af8f9418c71021e1 /packages/strace
parent395129424bf741ae06cee6d1b8939b0f75fef180 (diff)
downloadopenembedded-b0fdd5d38e3b9643df309243d62c8ffde88d141f.tar.gz
packages/strace: Apply patch from uclibc buildroot to fix compilation uclibc angstrom
Without that patch the Angstrom uclibc EABI build fails. Patch was taken from the buildroot of uclibc.
Diffstat (limited to 'packages/strace')
-rw-r--r--packages/strace/strace/strace-undef-syscall.patch66
-rw-r--r--packages/strace/strace_4.5.14.bb3
2 files changed, 68 insertions, 1 deletions
diff --git a/packages/strace/strace/strace-undef-syscall.patch b/packages/strace/strace/strace-undef-syscall.patch
new file mode 100644
index 0000000000..95166ea18a
--- /dev/null
+++ b/packages/strace/strace/strace-undef-syscall.patch
@@ -0,0 +1,66 @@
+Origin is http://buildroot.uclibc.org/cgi-bin/viewcvs.cgi/*checkout*/trunk/buildroot/package/strace/strace-undef-syscall.patch?rev=17767
+
+This gets applied to fix build errors with uclibc on ARM EABI
+
+--- strace-4.5.12/linux/syscallent.h.orig 2005-08-09 01:48:54.000000000 -0600
++++ strace-4.5.12/linux/syscallent.h 2005-08-09 01:50:23.000000000 -0600
+@@ -298,7 +298,11 @@
+ { 3, 0, sys_io_cancel, "io_cancel" }, /* 249 */
+ { 5, TF, sys_fadvise64, "fadvise64" }, /* 250 */
+ { 5, 0, printargs, "SYS_251" }, /* 251 */
+- { 1, TP, sys_exit, "exit_group", __NR_exit_group }, /* 252 */
++ { 1, TP, sys_exit, "exit_group"
++#ifdef __NR_exit_group
++ , __NR_exit_group
++#endif
++ }, /* 252 */
+ { 4, 0, printargs, "lookup_dcookie"}, /* 253 */
+ { 1, 0, sys_epoll_create, "epoll_create" }, /* 254 */
+ { 4, 0, sys_epoll_ctl, "epoll_ctl" }, /* 255 */
+--- strace-4.5.15.orig/linux/syscallent.h 2007-02-04 19:03:48.000000000 +0100
++++ strace-4.5.15/linux/syscallent.h 2007-02-04 19:11:04.000000000 +0100
+@@ -130,7 +130,10 @@
+ { 2, TF, sys_statfs, "statfs" }, /* 99 */
+ { 2, TD, sys_fstatfs, "fstatfs" }, /* 100 */
+ { 3, 0, sys_ioperm, "ioperm" }, /* 101 */
+- { 2, TD, sys_socketcall, "socketcall", SYS_socketcall }, /* 102 */
++ { 2, TD, sys_socketcall, "socketcall",
++#ifdef __NR_socketcall
++ SYS_socketcall }, /* 102 */
++#endif
+ { 3, 0, sys_syslog, "syslog" }, /* 103 */
+ { 3, 0, sys_setitimer, "setitimer" }, /* 104 */
+ { 2, 0, sys_getitimer, "getitimer" }, /* 105 */
+@@ -145,7 +148,10 @@
+ { 4, TP, sys_wait4, "wait4", SYS_wait4 }, /* 114 */
+ { 1, 0, sys_swapoff, "swapoff" }, /* 115 */
+ { 1, 0, sys_sysinfo, "sysinfo" }, /* 116 */
+- { 6, 0, sys_ipc, "ipc", SYS_ipc }, /* 117 */
++ { 6, 0, sys_ipc, "ipc",
++#ifdef __NR_ipc
++ SYS_ipc }, /* 117 */
++#endif
+ { 1, TD, sys_fsync, "fsync" }, /* 118 */
+ { 1, TS, sys_sigreturn, "sigreturn" }, /* 119 */
+ { 5, TP, sys_clone, "clone", SYS_clone }, /* 120 */
+--- strace-4.5.15.orig/syscall.c 2007-02-04 19:03:48.000000000 +0100
++++ strace-4.5.15/syscall.c 2007-02-04 19:07:26.000000000 +0100
+@@ -2404,14 +2404,18 @@
+ switch (known_scno(tcp)) {
+ #ifdef LINUX
+ #if !defined (ALPHA) && !defined(SPARC) && !defined(SPARC64) && !defined(MIPS) && !defined(HPPA)
++#ifdef __NR_socketcall
+ case SYS_socketcall:
+ decode_subcall(tcp, SYS_socket_subcall,
+ SYS_socket_nsubcalls, deref_style);
+ break;
++#endif
++#ifdef __NR_ipc
+ case SYS_ipc:
+ decode_subcall(tcp, SYS_ipc_subcall,
+ SYS_ipc_nsubcalls, shift_style);
+ break;
++#endif
+ #endif /* !ALPHA && !MIPS && !SPARC && !SPARC64 && !HPPA */
+ #if defined (SPARC) || defined (SPARC64)
+ case SYS_socketcall:
diff --git a/packages/strace/strace_4.5.14.bb b/packages/strace/strace_4.5.14.bb
index b301d0100b..50baef86dc 100644
--- a/packages/strace/strace_4.5.14.bb
+++ b/packages/strace/strace_4.5.14.bb
@@ -9,7 +9,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
file://drop-ctl-proc.patch;patch=1 \
file://sh-arch-update.patch;patch=1 \
file://sh-syscall-update.patch;patch=1 \
- file://strace-fix-arm-bad-syscall.patch;patch=1"
+ file://strace-fix-arm-bad-syscall.patch;patch=1 \
+ file://strace-undef-syscall.patch;patch=1 "
inherit autotools