aboutsummaryrefslogtreecommitdiffstats
path: root/packages/strace
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-05-16 03:55:05 +0000
committerKhem Raj <raj.khem@gmail.com>2008-05-16 03:55:05 +0000
commite4068ea40e02f149c1d4fbd7ec4b7686bf056f80 (patch)
tree2a56addece8ab9a8724d91e8d7f4dcb556053ecb /packages/strace
parent58094e2efaf669d7cf5ebd0405217a610e6cc0da (diff)
downloadopenembedded-e4068ea40e02f149c1d4fbd7ec4b7686bf056f80.tar.gz
Do not include cachectl.h for arm.
Diffstat (limited to 'packages/strace')
-rw-r--r--packages/strace/strace-4.5.14/strace-arm-no-cachectl.patch34
-rw-r--r--packages/strace/strace_4.5.14.bb3
2 files changed, 36 insertions, 1 deletions
diff --git a/packages/strace/strace-4.5.14/strace-arm-no-cachectl.patch b/packages/strace/strace-4.5.14/strace-arm-no-cachectl.patch
new file mode 100644
index 0000000000..b71995dbdf
--- /dev/null
+++ b/packages/strace/strace-4.5.14/strace-arm-no-cachectl.patch
@@ -0,0 +1,34 @@
+
+
+This patch is needed on newer uclibc becuase the uclibc header generation mechanism generates the sysnum.h properly NR_cacheflush is defined for ARM but there is no cachectl.h file which is exported to userspace. Strace assumes that if SYS_cacheflush is defined than it icludes asm/cachectl.h which breaks the build for ARM now.
+
+This patch adds a check for ARM architecture.
+
+-Khem
+
+Here is error
+
+| if ccache arm-angstrom-linux-uclibcgnueabi-gcc -march=armv5te -mtune=arm926ej-s -DHAVE_CONFIG_H -I. -I. -I. -Ilinux/arm -I./linux/arm -Ilinux -I./linux -isystem/home/kraj/work/oe/build/uclibc/tmp-omap5912osk/staging/arm-angstrom-linux-uclibcgnueabi/usr/include -Wall -isystem/home/kraj/work/oe/build/uclibc/tmp-omap5912osk/staging/arm-angstrom-linux-uclibcgnueabi/usr/include -fexpensive-optimizations -fomit-frame-pointer -frename-registers -Os -MT term.o -MD -MP -MF ".deps/term.Tpo" -c -o term.o term.c; \
+| then mv -f ".deps/term.Tpo" ".deps/term.Po"; else rm -f ".deps/term.Tpo"; exit 1; fi
+| system.c:69:26: error: asm/cachectl.h: No such file or directory
+| make[1]: *** [system.o] Error 1
+| make[1]: *** Waiting for unfinished jobs....
+| signal.c: In function 'sys_sigreturn':
+| signal.c:1221: warning: passing argument 4 of 'ptrace' makes integer from pointer without a cast
+| make[1]: Leaving directory `/home/kraj/work/oe/build/uclibc/tmp-omap5912osk/work/armv5te-angstrom-linux-uclibcgnueabi/strace-4.5.14-r5/strace-4.5.14'
+| make: *** [all] Error 2
+| FATAL: oe_runmake failed
+
+Index: strace-4.5.14/system.c
+===================================================================
+--- strace-4.5.14.orig/system.c 2008-05-15 20:23:16.000000000 -0700
++++ strace-4.5.14/system.c 2008-05-15 20:24:03.000000000 -0700
+@@ -65,7 +65,7 @@
+ #include <linux/capability.h>
+ #endif
+
+-#ifdef SYS_cacheflush
++#if defined SYS_cacheflush && !defined ARM
+ #include <asm/cachectl.h>
+ #endif
+
diff --git a/packages/strace/strace_4.5.14.bb b/packages/strace/strace_4.5.14.bb
index e65ac2d04e..0571c466d5 100644
--- a/packages/strace/strace_4.5.14.bb
+++ b/packages/strace/strace_4.5.14.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "strace is a system call tracing tool."
SECTION = "console/utils"
LICENSE = "GPL"
-PR = "r5"
+PR = "r6"
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
file://glibc-2.5.patch;patch=1 \
@@ -11,6 +11,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
file://sh-syscall-update.patch;patch=1 \
file://strace-fix-arm-bad-syscall.patch;patch=1 \
file://strace-undef-syscall.patch;patch=1 \
+ file://strace-arm-no-cachectl.patch;patch=1 \
"