aboutsummaryrefslogtreecommitdiffstats
path: root/packages/subapplet
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2004-12-22 09:18:22 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2004-12-22 09:18:22 +0000
commita963f3896374d0ea65cf63626aea7940567993c7 (patch)
treef723621ec763b08398aadd20f072a62f159125bc /packages/subapplet
parentedbe8f99e47fa78a723735cab04e172ecee3a4b6 (diff)
downloadopenembedded-a963f3896374d0ea65cf63626aea7940567993c7.tar.gz
subapplet: fixed toolbar resizing
BKrev: 41c93bdeJuFI5dVLUmNmR8eI2F3sdw
Diffstat (limited to 'packages/subapplet')
-rw-r--r--packages/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch (renamed from packages/subapplet/subapplet-1.0.8/subapplet.pro.patch)0
-rw-r--r--packages/subapplet/subapplet_1.0.8.bb40
2 files changed, 40 insertions, 0 deletions
diff --git a/packages/subapplet/subapplet-1.0.8/subapplet.pro.patch b/packages/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/subapplet/subapplet-1.0.8/subapplet.pro.patch
+++ b/packages/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch
diff --git a/packages/subapplet/subapplet_1.0.8.bb b/packages/subapplet/subapplet_1.0.8.bb
index e69de29bb2..08cbf9b64e 100644
--- a/packages/subapplet/subapplet_1.0.8.bb
+++ b/packages/subapplet/subapplet_1.0.8.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Applet for the Qtopia environment taskbar that provides an extension panel \
+for the taskbar that let's you load lot's of applet's without taking up space \
+in the normal taskbar."
+SECTION = "opie/applets"
+PRIORITY = "optional"
+LICENSE = "GPL"
+MAINTAINER = "Marcin Juszkiewicz <openembedded@hrw.one.pl>"
+HOMEPAGE = "http://sourceforge.net/projects/subapplet/"
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/subapplet/subapplet-1.0.8.tar.gz \
+ file://toolbar-resize-fix.patch;patch=1"
+
+S = "${WORKDIR}/SubApplet-1.0.8"
+
+inherit palmtop
+
+QMAKE_PROFILES = "subapplet.pro"
+
+do_install() {
+ install -d ${D}/${palmtopdir}/plugins/applets ${D}/${palmtopdir}/pics/subapplet/
+ install -m 0644 *.png ${D}/${palmtopdir}/pics/subapplet/
+ oe_libinstall -so -C rel${palmtopdir}/plugins/applets libsubapplet ${D}/${palmtopdir}/plugins/applets/
+}
+
+pkg_postinst() {
+#!/bin/sh
+if pidof -s qpe >/dev/null; then
+ /opt/QtPalmtop/bin/qcop QPE/TaskBar "reloadApplets()"
+else
+ exit 0
+fi
+ if [ -n "$D" ]; then false; fi
+}
+
+pkg_postrm() {
+#!/bin/sh
+/opt/QtPalmtop/bin/qcop QPE/TaskBar "reloadApplets()"
+ if [ -n "$D" ]; then false; fi
+}