aboutsummaryrefslogtreecommitdiffstats
path: root/packages/subversion
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-05-08 19:22:08 +0000
committerMichael Krelin <hacker@klever.net>2007-05-08 19:22:08 +0000
commit02fb4610922c0944aa90b668b1238949a6bb3535 (patch)
treeffebabb22d1608d75d9b9d10afb202b5dc6df363 /packages/subversion
parent2f1e00624712c31cfc2bd55a8d46ae5dab187de9 (diff)
downloadopenembedded-02fb4610922c0944aa90b668b1238949a6bb3535.tar.gz
subversion: added a patch to detect neon and enable dav protocol handler
Diffstat (limited to 'packages/subversion')
-rw-r--r--packages/subversion/files/neon-detection.patch36
-rw-r--r--packages/subversion/subversion_1.4.0.bb9
2 files changed, 42 insertions, 3 deletions
diff --git a/packages/subversion/files/neon-detection.patch b/packages/subversion/files/neon-detection.patch
new file mode 100644
index 0000000000..b567d5c050
--- /dev/null
+++ b/packages/subversion/files/neon-detection.patch
@@ -0,0 +1,36 @@
+diff --git a/build/ac-macros/neon.m4 b/build/ac-macros/neon.m4
+index 9fcf859..8d964f3 100644
+--- a/build/ac-macros/neon.m4
++++ b/build/ac-macros/neon.m4
+@@ -38,7 +38,7 @@ AC_DEFUN(SVN_LIB_NEON,
+ if test "$withval" = "yes" ; then
+ AC_MSG_ERROR([--with-neon requires an argument.])
+ else
+- neon_config="$withval/bin/neon-config"
++ neon_config="env env PKG_CONFIG_PATH=${withval}:${PKG_CONFIG_PATH} pkg-config neon"
+ fi
+
+ SVN_NEON_CONFIG()
+@@ -117,10 +117,10 @@ dnl SVN_NEON_CONFIG()
+ dnl neon-config found, gather relevant information from it
+ AC_DEFUN(SVN_NEON_CONFIG,
+ [
+- if test -f "$neon_config"; then
+- if test "$neon_config" != ""; then
++ if true; then
++ if true; then
+ AC_MSG_CHECKING([neon library version])
+- NEON_VERSION=`$neon_config --version | sed -e 's/^neon //'`
++ NEON_VERSION=`$neon_config --modversion | sed -e 's/^neon //'`
+ AC_MSG_RESULT([$NEON_VERSION])
+
+ if test -n "`echo \"$NEON_VERSION\" | grep '^0\.25\.'`" ; then
+@@ -133,7 +133,7 @@ AC_DEFUN(SVN_NEON_CONFIG,
+ test "$svn_allowed_neon" = "any"; then
+ svn_allowed_neon_on_system="yes"
+ SVN_NEON_INCLUDES=[`$neon_config --cflags | sed -e 's/-D[^ ]*//g'`]
+- NEON_LIBS=`$neon_config --la-file`
++ NEON_LIBS=`$neon_config --libs`
+ CFLAGS=["$CFLAGS `$neon_config --cflags | sed -e 's/-I[^ ]*//g'`"]
+ svn_lib_neon="yes"
+ break
diff --git a/packages/subversion/subversion_1.4.0.bb b/packages/subversion/subversion_1.4.0.bb
index 3c65d1d0a8..a608aac063 100644
--- a/packages/subversion/subversion_1.4.0.bb
+++ b/packages/subversion/subversion_1.4.0.bb
@@ -1,14 +1,16 @@
DESCRIPTION = "The Subversion (svn) client"
SECTION = "console/network"
DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
LICENSE = "Apache/BSD"
HOMEPAGE = "http://subversion.tigris.org"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
- file://disable-revision-install.patch;patch=1"
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1"
-EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${BUILD_SYS} \
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
--without-berkeley-db --without-apxs --without-apache \
--without-swig --with-apr=${STAGING_BINDIR_CROSS} \
--with-apr-util=${STAGING_BINDIR_CROSS}"
@@ -21,5 +23,6 @@ export LDFLAGS += " -L${STAGING_LIBDIR} "
do_configure() {
gnu-configize
libtoolize --force
+ aclocal -I build/ -I build/ac-macros/ && autoconf
oe_runconf
}