aboutsummaryrefslogtreecommitdiffstats
path: root/packages/subversion
diff options
context:
space:
mode:
authorMichael Krelin <hacker@klever.net>2007-05-09 11:56:33 +0000
committerMichael Krelin <hacker@klever.net>2007-05-09 11:56:33 +0000
commit3fa28ce7bf9832b9705266acc8da9e5ae1f5e6cd (patch)
treeccd0c4c2712a01bf87336384783286af403d354e /packages/subversion
parent9b390a0b2e0a84bfc53c8ea174d36402c9971599 (diff)
downloadopenembedded-3fa28ce7bf9832b9705266acc8da9e5ae1f5e6cd.tar.gz
subversion: added 1.4.3 version with DEFAULT_PREFERENCE of -1.
this version seems to accept neon 0.26 without brute force, which in turn doesn't need force to use gnutls.
Diffstat (limited to 'packages/subversion')
-rw-r--r--packages/subversion/subversion_1.4.3.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/subversion/subversion_1.4.3.bb b/packages/subversion/subversion_1.4.3.bb
new file mode 100644
index 0000000000..c0a2a02e08
--- /dev/null
+++ b/packages/subversion/subversion_1.4.3.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache/BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ aclocal -I build/ -I build/ac-macros/ && autoconf
+ oe_runconf
+}