aboutsummaryrefslogtreecommitdiffstats
path: root/packages/subversion
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2007-11-29 17:55:16 +0000
committerMatthias Hentges <oe@hentges.net>2007-11-29 17:55:16 +0000
commit9f140d40ddecfaf63708117ed113fc6fd6cc699f (patch)
treef9f78de36b7be38ae02341e8a5dd1407c75ff602 /packages/subversion
parent3b0a73545371730ebe36bf749de235cd429203ff (diff)
downloadopenembedded-9f140d40ddecfaf63708117ed113fc6fd6cc699f.tar.gz
subversion: Add version 1.4.5
Diffstat (limited to 'packages/subversion')
-rw-r--r--packages/subversion/subversion_1.4.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/subversion/subversion_1.4.5.bb b/packages/subversion/subversion_1.4.5.bb
new file mode 100644
index 0000000000..1daf45bd0c
--- /dev/null
+++ b/packages/subversion/subversion_1.4.5.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "The Subversion (svn) client"
+SECTION = "console/network"
+DEPENDS = "apr-util neon"
+RDEPENDS = "neon"
+LICENSE = "Apache BSD"
+HOMEPAGE = "http://subversion.tigris.org"
+
+PR = "r0"
+
+SRC_URI = "http://subversion.tigris.org/downloads/${P}.tar.bz2 \
+ file://disable-revision-install.patch;patch=1 \
+ file://neon-detection.patch;patch=1"
+
+EXTRA_OECONF = "--with-neon=${STAGING_DIR}/${TARGET_SYS} \
+ --without-berkeley-db --without-apxs --without-apache \
+ --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
+ --with-apr-util=${STAGING_BINDIR_CROSS}"
+
+
+inherit autotools
+
+export LDFLAGS += " -L${STAGING_LIBDIR} "
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ aclocal -I build/ -I build/ac-macros/ && autoconf
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}