aboutsummaryrefslogtreecommitdiffstats
path: root/packages/suspend-desktop
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2005-11-21 11:41:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-21 11:41:15 +0000
commit5c243ea0c692f54a7c1540874001a745ac10582c (patch)
treeb2971ee291fec90d42e0b7cbccae7c2a4c17a9cf /packages/suspend-desktop
parent58d98d5b50de03139c064da4aadb6400676a3d82 (diff)
downloadopenembedded-5c243ea0c692f54a7c1540874001a745ac10582c.tar.gz
suspend-desktop: New package providing a desktop entry to suspend some devices using apm or the pm helper.
Diffstat (limited to 'packages/suspend-desktop')
-rw-r--r--packages/suspend-desktop/.mtn2git_empty0
-rw-r--r--packages/suspend-desktop/suspend-desktop_1.0.bb26
-rw-r--r--packages/suspend-desktop/suspend.desktop9
-rw-r--r--packages/suspend-desktop/suspend.sh10
4 files changed, 45 insertions, 0 deletions
diff --git a/packages/suspend-desktop/.mtn2git_empty b/packages/suspend-desktop/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/suspend-desktop/.mtn2git_empty
diff --git a/packages/suspend-desktop/suspend-desktop_1.0.bb b/packages/suspend-desktop/suspend-desktop_1.0.bb
new file mode 100644
index 0000000000..4586b61978
--- /dev/null
+++ b/packages/suspend-desktop/suspend-desktop_1.0.bb
@@ -0,0 +1,26 @@
+PR = "r0"
+SECTION = "gpe"
+PRIORITY = "optional"
+DESCRIPTION = "Suspend feature for the application launcher menu."
+MAINTAINER = "Florian Boor <florian@kernelconcepts.de>"
+LICENSE = "GPL"
+DEPENDS = "gpe-conf"
+RDEPENDS = "gpe-conf"
+RRECOMMENDS = "apm"
+PACKAGES = ${PN}
+
+
+SRC_URI = "file://suspend.desktop \
+ file://suspend.sh"
+
+FILES_${PN} = "${bindir} ${datadir}"
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -d ${D}/${datadir}/applications
+ install -m644 ${WORKDIR}/suspend.desktop ${D}/${datadir}/applications/suspend.desktop
+ install -m755 ${WORKDIR}/suspend.sh ${D}/${bindir}/suspend.sh
+}
diff --git a/packages/suspend-desktop/suspend.desktop b/packages/suspend-desktop/suspend.desktop
new file mode 100644
index 0000000000..21da51a66c
--- /dev/null
+++ b/packages/suspend-desktop/suspend.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Suspend
+Comment=Suspend device
+Exec=/usr/bin/suspend.sh
+Terminal=0
+Type=Application
+Icon=gpe-config-sleep.png
+Categories=Utility;GPE;Action
+StartupNotify=False
diff --git a/packages/suspend-desktop/suspend.sh b/packages/suspend-desktop/suspend.sh
new file mode 100644
index 0000000000..990bc09949
--- /dev/null
+++ b/packages/suspend-desktop/suspend.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+if [ -x /usr/bin/apm ]
+then
+ /usr/bin/apm --suspend
+else
+ if [ -x /usr/bin/pm ]
+ then
+ /usr/bin/pm -pp
+ fi
+fi