aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sword
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-12-05 18:23:25 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-12-05 18:23:25 +0000
commit2b1a9b11bfdfae3518f7a91936a60b7d8f69e114 (patch)
treee306a04fe7737f7958b1e41709d8c32be9f5878e /packages/sword
parent4ae600c96567dfe5b95f89e58e7c69466ff981ae (diff)
downloadopenembedded-2b1a9b11bfdfae3518f7a91936a60b7d8f69e114.tar.gz
sword 1.5.8: Fix staging, inherit pkgconfig and add curl support
Diffstat (limited to 'packages/sword')
-rw-r--r--packages/sword/sword_1.5.8.bb15
1 files changed, 5 insertions, 10 deletions
diff --git a/packages/sword/sword_1.5.8.bb b/packages/sword/sword_1.5.8.bb
index d4f1e6189e..8bb469295f 100644
--- a/packages/sword/sword_1.5.8.bb
+++ b/packages/sword/sword_1.5.8.bb
@@ -5,20 +5,15 @@ Bible software with a constantly growing list of front-ends \
SECTION = "libs"
PRIORITY = "optional"
LICENSE = "GPL"
+DEPENDS = "curl"
+PR ="r1"
SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
-inherit autotools
+inherit autotools pkgconfig
-EXTRA_OECONF = "--without-clucene --without-curl"
+EXTRA_OECONF = "--without-clucene --with-curl"
do_stage() {
- oe_libinstall -so -C lib libsword ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/sword/
- for f in include/*.h
- do
- install -m 0644 $f ${STAGING_INCDIR}/sword/
- done
-
+autotools_stage_all
}