aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sword
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-06-30 16:05:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-30 16:05:46 +0000
commit2bb99a3166b4105f94036e4f11fd4c7915f496a7 (patch)
tree59192a716a358e46e55e77167291561526bfcde4 /packages/sword
parent3c43af234dfe9e652cb388161c425b6dd5d507db (diff)
downloadopenembedded-2bb99a3166b4105f94036e4f11fd4c7915f496a7.tar.gz
sword: fix packaging so -dev will not contain libs
Diffstat (limited to 'packages/sword')
-rw-r--r--packages/sword/sword_1.5.8.bb16
1 files changed, 12 insertions, 4 deletions
diff --git a/packages/sword/sword_1.5.8.bb b/packages/sword/sword_1.5.8.bb
index 8bb469295f..b16e1fb013 100644
--- a/packages/sword/sword_1.5.8.bb
+++ b/packages/sword/sword_1.5.8.bb
@@ -5,15 +5,23 @@ Bible software with a constantly growing list of front-ends \
SECTION = "libs"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = "curl"
-PR ="r1"
+PR = "r2"
SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
inherit autotools pkgconfig
-EXTRA_OECONF = "--without-clucene --with-curl"
+EXTRA_OECONF = "--without-clucene --without-curl"
do_stage() {
-autotools_stage_all
+ oe_libinstall -so -C lib libsword ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/sword/
+ for f in include/*.h
+ do
+ install -m 0644 $f ${STAGING_INCDIR}/sword/
+ done
+
}
+
+FILES_${PN} = "${libdir}/libsword*so ${sysconfdir} ${bindir} ${datadir}"