aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-05-30 13:56:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-30 13:56:36 +0000
commit135dd94094b635ef1a3e7935c4d9d5ca0204698b (patch)
tree2f7374de5372461818d254a51aaabca148d93657 /packages/sylpheed
parent3e70f1f55a14b23a43512452aae21c1ad1f219eb (diff)
downloadopenembedded-135dd94094b635ef1a3e7935c4d9d5ca0204698b.tar.gz
sylpheed_2.2.5.bb : new version
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/sylpheed_2.2.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed_2.2.5.bb b/packages/sylpheed/sylpheed_2.2.5.bb
new file mode 100644
index 0000000000..1a1656e539
--- /dev/null
+++ b/packages/sylpheed/sylpheed_2.2.5.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPL"
+PR = "r5"
+
+SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.2/sylpheed-${PV}.tar.bz2 \
+ file://sylpheed-2.2.2-libsylph-Makefile-am.patch;patch=1 \
+ file://sylpheed-2.2.2-src-Makefile-am.patch;patch=1 \
+ file://sylpheed-gnutls_2.2.4.patch;patch=1"
+
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN}-doc += "${datadir}"
+
+EXTRA_OECONF = "--enable-gnutls --disable-pthread"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed.png ${D}${datadir}/pixmaps/
+}
+