aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-02-06 12:15:02 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-02-06 12:15:02 +0000
commit194db10e49ea97af6520ca66591e5e585f24c1c1 (patch)
treee26cf5904c37c719af597ce2852761e0f5aced3d /packages/sylpheed
parent4bac67ace7a25f0db5daffb6ac2900bcb07e7240 (diff)
downloadopenembedded-194db10e49ea97af6520ca66591e5e585f24c1c1.tar.gz
claws-mail_2.7.2.bb : new version of claws
claws-plugin-*.bb : new versions of plugins for claws mail.
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/claws-mail_2.7.2.bb41
-rw-r--r--packages/sylpheed/claws-plugin-gtkhtml2-viewer_0.14.1.bb20
-rw-r--r--packages/sylpheed/claws-plugin-maildir_0.24.4.bb20
-rw-r--r--packages/sylpheed/claws-plugin-mailmbox_1.12.4.bb20
-rw-r--r--packages/sylpheed/claws-plugin-rssyl_0.10.bb20
5 files changed, 121 insertions, 0 deletions
diff --git a/packages/sylpheed/claws-mail_2.7.2.bb b/packages/sylpheed/claws-mail_2.7.2.bb
new file mode 100644
index 0000000000..bed205766b
--- /dev/null
+++ b/packages/sylpheed/claws-mail_2.7.2.bb
@@ -0,0 +1,41 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme libetpan libgnomeprint aspell"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2"
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+
+EXTRA_OECONF = "--disable-openssl --disable-aspell-test \
+ --disable-dillo-viewer-plugin --with-aspell-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --enable-aspell"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+inherit autotools pkgconfig
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 claws-mail.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
+ mv ${D}${bindir}/${TARGET_SYS}-claws-mail ${D}${bindir}/${PN}
+}
+
+do_stage () {
+ autotools_stage_all
+}
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/claws-mail/plugins', d)
+
+ do_split_packages(d, abiword_libdir, '^(.*)\.so$', 'claws-mail-plugin-%s', 'Claws plugin for %s', extra_depends='')
+}
diff --git a/packages/sylpheed/claws-plugin-gtkhtml2-viewer_0.14.1.bb b/packages/sylpheed/claws-plugin-gtkhtml2-viewer_0.14.1.bb
new file mode 100644
index 0000000000..5ca95d9dfb
--- /dev/null
+++ b/packages/sylpheed/claws-plugin-gtkhtml2-viewer_0.14.1.bb
@@ -0,0 +1,20 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent plugins"
+DEPENDS = "claws-mail gtkhtml2 curl"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.claws-mail.org/downloads/plugins/gtkhtml2_viewer-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/gtkhtml2_viewer-${PV}"
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+FILES_${PN} = "${libdir}/claws-mail/plugins/*.so"
+
diff --git a/packages/sylpheed/claws-plugin-maildir_0.24.4.bb b/packages/sylpheed/claws-plugin-maildir_0.24.4.bb
new file mode 100644
index 0000000000..6032e09918
--- /dev/null
+++ b/packages/sylpheed/claws-plugin-maildir_0.24.4.bb
@@ -0,0 +1,20 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent plugins"
+DEPENDS = "claws-mail db"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.claws-mail.org/downloads/plugins/maildir-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/maildir-${PV}"
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+FILES_${PN} = "${libdir}/claws-mail/plugins/*.so"
+
diff --git a/packages/sylpheed/claws-plugin-mailmbox_1.12.4.bb b/packages/sylpheed/claws-plugin-mailmbox_1.12.4.bb
new file mode 100644
index 0000000000..d1f9e22d22
--- /dev/null
+++ b/packages/sylpheed/claws-plugin-mailmbox_1.12.4.bb
@@ -0,0 +1,20 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent plugins"
+DEPENDS = "claws-mail"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.claws-mail.org/downloads/plugins/mailmbox-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/mailmbox-${PV}"
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+FILES_${PN} = "${libdir}/claws-mail/plugins/*.so"
+
diff --git a/packages/sylpheed/claws-plugin-rssyl_0.10.bb b/packages/sylpheed/claws-plugin-rssyl_0.10.bb
new file mode 100644
index 0000000000..29fc245ac4
--- /dev/null
+++ b/packages/sylpheed/claws-plugin-rssyl_0.10.bb
@@ -0,0 +1,20 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent plugins"
+DEPENDS = "claws-mail libxml2 curl glib-2.0 gtk+"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.claws-mail.org/downloads/plugins/rssyl-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/rssyl-${PV}"
+
+do_configure() {
+ gnu-configize
+ libtoolize --force
+ oe_runconf
+}
+
+FILES_${PN} = "${libdir}/claws-mail/plugins/*.so"
+