aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-05-09 12:26:14 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-09 12:26:14 +0000
commit218ddf031b7d5ea3ffb795adb1a0ddfc2cd32aa3 (patch)
treec01efd2047822262eb6ed27e364dcf1a5b0cccd5 /packages/sylpheed
parentba713f6d2774c1fece3fefdec4ccae1f271b586b (diff)
downloadopenembedded-218ddf031b7d5ea3ffb795adb1a0ddfc2cd32aa3.tar.gz
packages/sylpheed/sylpheed-claws_2.2.0.bb : stage stuff for plugins
packages/sylpheed/sylpheed-claws-plugin-rssyl_2.2.0.bb : add rss plugin for sylpheed-claws. Also includes generic framework for enabling the others
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/sylpheed-claws-extra-plugins.inc12
-rw-r--r--packages/sylpheed/sylpheed-claws-plugin-rssyl_2.2.0.bb8
-rw-r--r--packages/sylpheed/sylpheed-claws_2.2.0.bb8
3 files changed, 26 insertions, 2 deletions
diff --git a/packages/sylpheed/sylpheed-claws-extra-plugins.inc b/packages/sylpheed/sylpheed-claws-extra-plugins.inc
new file mode 100644
index 0000000000..624abc105a
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws-extra-plugins.inc
@@ -0,0 +1,12 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent plugins"
+DEPENDS = "sylpheed-claws"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sylpheed-claws/sylpheed-claws-extra-plugins-${PV}.tar.bz2"
+
+
+inherit autotools pkgconfig
+
diff --git a/packages/sylpheed/sylpheed-claws-plugin-rssyl_2.2.0.bb b/packages/sylpheed/sylpheed-claws-plugin-rssyl_2.2.0.bb
new file mode 100644
index 0000000000..6299da3d5d
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws-plugin-rssyl_2.2.0.bb
@@ -0,0 +1,8 @@
+include sylpheed-claws-extra-plugins.inc
+
+DEPENDS_append = " libxml2 curl glib-2.0 gtk+"
+
+S = ${WORKDIR}/sylpheed-claws-extra-plugins-${PV}/rssyl-0.4cvs8
+
+FILES_${PN} = "${libdir}/sylpheed-claws/plugins/rssyl.so"
+
diff --git a/packages/sylpheed/sylpheed-claws_2.2.0.bb b/packages/sylpheed/sylpheed-claws_2.2.0.bb
index 9cdcbcd80b..0308e60964 100644
--- a/packages/sylpheed/sylpheed-claws_2.2.0.bb
+++ b/packages/sylpheed/sylpheed-claws_2.2.0.bb
@@ -5,7 +5,7 @@ MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
LICENSE = "GPL"
PR = "r0"
-SRC_URI = "${SOURCEFORGE_MIRROR}/sylpheed-claws/sylpheed-claws-2.2.0.tar.bz2"
+SRC_URI = "${SOURCEFORGE_MIRROR}/sylpheed-claws/sylpheed-claws-${PV}.tar.bz2"
FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
@@ -20,7 +20,7 @@ do_configure_prepend() {
mkdir -p m4
}
-inherit autotools
+inherit autotools pkgconfig
do_install_append() {
install -d ${D}${datadir}/applications
@@ -29,3 +29,7 @@ do_install_append() {
install -m 0644 sylpheed-claws.png ${D}${datadir}/pixmaps/
}
+do_stage () {
+ autotools_stage_all
+}
+