aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-09-18 12:38:34 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-09-18 12:38:34 +0000
commit4511db46f10b604fb1feede0ae30b3aa8c844952 (patch)
treeba641fcc2281c686b0c642bd76a857ea3fb69a0c /packages/sylpheed
parent977f72d6866b1b8f9c18b1f5a363bca0132ed655 (diff)
downloadopenembedded-4511db46f10b604fb1feede0ae30b3aa8c844952.tar.gz
sylpheed/claws-mail_3.0.1.bb : new version
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/claws-mail_3.0.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/sylpheed/claws-mail_3.0.1.bb b/packages/sylpheed/claws-mail_3.0.1.bb
new file mode 100644
index 0000000000..29e7a5bc63
--- /dev/null
+++ b/packages/sylpheed/claws-mail_3.0.1.bb
@@ -0,0 +1,43 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ libetpan openssl aspell"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2 \
+ file://desktop.patch;patch=1 \
+ "
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+
+EXTRA_OECONF = "--disable-aspell-test \
+ --enable--aspell \
+ --disable-manual \
+ --disable-crash-dialog \
+ --disable-jpilot \
+ --disable-trayicon-plugin \
+ --disable-spamassassin-plugin \
+ --disable-bogofilter-plugin \
+ --disable-pgpcore-plugin \
+ --disable-pgpmime-plugin \
+ --disable-pgpinline-plugin \
+ --disable-dillo-viewer-plugin \
+ --disable-clamav-plugin \
+ --disable-gnomeprint \
+ --disable-valgrind \
+ "
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 claws-mail.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
+}
+
+do_stage () {
+ autotools_stage_all
+}
+