aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-06-12 12:26:16 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-12 12:26:16 +0000
commitfde62dc6e3a4eed3b138f07db46c0aeeba6608bf (patch)
tree6f883ea569ed1f2f99b4708675a839e7f5313bcc /packages/sylpheed
parent457ca2bf9525f9b2fde7b67ecdd408b6418de5df (diff)
downloadopenembedded-fde62dc6e3a4eed3b138f07db46c0aeeba6608bf.tar.gz
sylpheed_2.2.6.bb : new version
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/sylpheed_2.2.6.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed_2.2.6.bb b/packages/sylpheed/sylpheed_2.2.6.bb
new file mode 100644
index 0000000000..3ea47c44dd
--- /dev/null
+++ b/packages/sylpheed/sylpheed_2.2.6.bb
@@ -0,0 +1,33 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.2/sylpheed-${PV}.tar.bz2 \
+ file://sylpheed-2.2.2-libsylph-Makefile-am.patch;patch=1 \
+ file://sylpheed-2.2.2-src-Makefile-am.patch;patch=1 \
+ file://sylpheed-gnutls_2.2.4.patch;patch=1"
+
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN}-doc += "${datadir}"
+
+EXTRA_OECONF = "--disable-ssl --enable-gnutls"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed.png ${D}${datadir}/pixmaps/
+}
+