aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-08-02 13:36:57 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-08-02 13:36:57 +0000
commit033b244ddc8f656841a3781cd8c237e0ec8be943 (patch)
tree89097e6f3c055c043485712dc65c02fb5241301a /packages/sylpheed
parent5b8d8a17269570faf8b169f1d7402ddab29b3e60 (diff)
downloadopenembedded-033b244ddc8f656841a3781cd8c237e0ec8be943.tar.gz
sylpheed-claws_2.4.0.bb : new version
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/sylpheed-claws_2.4.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/sylpheed/sylpheed-claws_2.4.0.bb b/packages/sylpheed/sylpheed-claws_2.4.0.bb
new file mode 100644
index 0000000000..0308e60964
--- /dev/null
+++ b/packages/sylpheed/sylpheed-claws_2.4.0.bb
@@ -0,0 +1,35 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme libetpan libgnomeprint aspell"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sylpheed-claws/sylpheed-claws-${PV}.tar.bz2"
+
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+
+EXTRA_OECONF = "--disable-aspell --disable-openssl --disable-aspell-test \
+ --disable-dillo-viewer-plugin --with-aspell-prefix=${STAGING_DIR}/${HOST_SYS} \
+ --enable-aspell"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools pkgconfig
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed-claws.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed-claws.png ${D}${datadir}/pixmaps/
+}
+
+do_stage () {
+ autotools_stage_all
+}
+