aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed
diff options
context:
space:
mode:
authorPatrick Steiner <law@a1.net>2005-07-21 09:06:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-21 09:06:06 +0000
commit4d0a097e128e46bd4c7616881f2b8a53acdd27c2 (patch)
tree8f2946a398fb2d3907a0d0a925146bdf58509313 /packages/sylpheed
parent2c81967e3792d8317c52e9fbfec5bb8a44ec8b7b (diff)
downloadopenembedded-4d0a097e128e46bd4c7616881f2b8a53acdd27c2.tar.gz
removed openssl from sylpheed again, added sylpheed-gnutls-extra.patch from XorA
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/files/sylpheed-gnutls-extra.patch37
-rw-r--r--packages/sylpheed/sylpheed_2.0.0beta6.bb7
2 files changed, 41 insertions, 3 deletions
diff --git a/packages/sylpheed/files/sylpheed-gnutls-extra.patch b/packages/sylpheed/files/sylpheed-gnutls-extra.patch
new file mode 100644
index 0000000000..ba24b5a1d7
--- /dev/null
+++ b/packages/sylpheed/files/sylpheed-gnutls-extra.patch
@@ -0,0 +1,37 @@
+--- sylpheed-2.0.0beta6/src/ssl.c.orig 2005-07-20 15:45:12.882201824 +0100
++++ sylpheed-2.0.0beta6/src/ssl.c 2005-07-20 16:10:04.006516472 +0100
+@@ -54,9 +54,9 @@
+ debug_print(_("SSLv23 not available\n"));
+ } else {
+ debug_print(_("SSLv23 available\n"));
+- if (certs_dir &&
++ if (certs_dir /*&&
+ !SSL_CTX_load_verify_locations(ssl_ctx_SSLv23, NULL,
+- certs_dir))
++ certs_dir)*/)
+ g_warning("SSLv23 SSL_CTX_load_verify_locations failed.\n");
+ }
+
+@@ -65,9 +65,9 @@
+ debug_print(_("TLSv1 not available\n"));
+ } else {
+ debug_print(_("TLSv1 available\n"));
+- if (certs_dir &&
++ if (certs_dir /*&&
+ !SSL_CTX_load_verify_locations(ssl_ctx_TLSv1, NULL,
+- certs_dir))
++ certs_dir)*/)
+ g_warning("TLSv1 SSL_CTX_load_verify_locations failed.\n");
+ }
+
+@@ -151,8 +151,8 @@
+ g_free(str);
+ }
+
+- verify_result = SSL_get_verify_result(sockinfo->ssl);
+- if (verify_result == X509_V_OK)
++ verify_result = 0; /*SSL_get_verify_result(sockinfo->ssl);*/
++ if (verify_result == 1)
+ debug_print("SSL verify OK\n");
+ else
+ g_warning("%s: SSL certificate verify failed (%ld: %s)\n",
diff --git a/packages/sylpheed/sylpheed_2.0.0beta6.bb b/packages/sylpheed/sylpheed_2.0.0beta6.bb
index 2c41c473f9..d95f21f343 100644
--- a/packages/sylpheed/sylpheed_2.0.0beta6.bb
+++ b/packages/sylpheed/sylpheed_2.0.0beta6.bb
@@ -1,12 +1,13 @@
SECTION = "x11/network"
DESCRIPTION = "Mail user agent"
-DEPENDS = "gtk+ gpgme gnutls openssl"
+DEPENDS = "gtk+ gpgme gnutls"
MAINTAINER = "Patrick Steiner <patrick.steiner@a1.net>"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.0beta/sylpheed-2.0.0beta6.tar.bz2 \
- file://sylpheed-gnutls_2.0.0beta6.patch;patch=1"
+ file://sylpheed-gnutls_2.0.0beta6.patch;patch=1 \
+ file://sylpheed-gnutls-extra.patch;patch=1 "
FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
FILES_${PN}-doc += "${datadir}"