aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-04-28 20:06:59 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-28 20:06:59 +0000
commit60d8ca72c7b5370ac01dfd87480d3d661fae0ca2 (patch)
treef45377fbbde20ca1d2b805c32f296d5cfa6000ca /packages/sylpheed
parent8f1261f002f8306057017e8e02be78d92dea4ddd (diff)
downloadopenembedded-60d8ca72c7b5370ac01dfd87480d3d661fae0ca2.tar.gz
sylpheed_2.2.4.bb : Really fix compiling with GnuTLS this time. I had
some openssl shrapnel in staging that gave me false positives. As a bonus I also had to forward port patches in gnutls. gnutls_1.3.5.bb : forward ported the openssl patches to this version of gnutls. This was an outstounding action from bug #725.
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/files/sylpheed-gnutls_2.2.4.patch47
-rw-r--r--packages/sylpheed/sylpheed_2.2.4.bb2
2 files changed, 48 insertions, 1 deletions
diff --git a/packages/sylpheed/files/sylpheed-gnutls_2.2.4.patch b/packages/sylpheed/files/sylpheed-gnutls_2.2.4.patch
index 05fbbb63c1..2bc27a484f 100644
--- a/packages/sylpheed/files/sylpheed-gnutls_2.2.4.patch
+++ b/packages/sylpheed/files/sylpheed-gnutls_2.2.4.patch
@@ -91,3 +91,50 @@
#include "socket.h"
+--- sylpheed-2.2.4/libsylph/ssl.c.orig 2006-04-28 20:38:46.000000000 +0100
++++ sylpheed-2.2.4/libsylph/ssl.c 2006-04-28 20:40:22.000000000 +0100
+@@ -54,9 +54,11 @@
+ debug_print(_("SSLv23 not available\n"));
+ } else {
+ debug_print(_("SSLv23 available\n"));
++#if USE_OPENSSL
+ if (certs_dir &&
+ !SSL_CTX_load_verify_locations(ssl_ctx_SSLv23, NULL,
+ certs_dir))
++#endif
+ g_warning("SSLv23 SSL_CTX_load_verify_locations failed.\n");
+ }
+
+@@ -65,9 +67,11 @@
+ debug_print(_("TLSv1 not available\n"));
+ } else {
+ debug_print(_("TLSv1 available\n"));
++#if USE_OPENSSL
+ if (certs_dir &&
+ !SSL_CTX_load_verify_locations(ssl_ctx_TLSv1, NULL,
+ certs_dir))
++#endif
+ g_warning("TLSv1 SSL_CTX_load_verify_locations failed.\n");
+ }
+
+@@ -151,14 +155,19 @@
+ g_free(str);
+ }
+
++#if USE_OPENSSL
+ verify_result = SSL_get_verify_result(sockinfo->ssl);
+ if (verify_result == X509_V_OK)
+ debug_print("SSL verify OK\n");
+ else
++#endif
+ g_warning("%s: SSL certificate verify failed (%ld: %s)\n",
+ sockinfo->hostname, verify_result,
++#if USE_OPENSSL
+ X509_verify_cert_error_string(verify_result));
+-
++#else
++ "Unsupport GnuTLS features");
++#endif
+ X509_free(server_cert);
+ }
+
diff --git a/packages/sylpheed/sylpheed_2.2.4.bb b/packages/sylpheed/sylpheed_2.2.4.bb
index 80ad0b6fe1..315f46ea86 100644
--- a/packages/sylpheed/sylpheed_2.2.4.bb
+++ b/packages/sylpheed/sylpheed_2.2.4.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Mail user agent"
DEPENDS = "gtk+ gpgme gnutls"
MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
LICENSE = "GPL"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.2/sylpheed-${PV}.tar.bz2 \
file://sylpheed-2.2.2-libsylph-Makefile-am.patch;patch=1 \