aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sylpheed
diff options
context:
space:
mode:
authorPatrick Steiner <law@a1.net>2005-07-24 18:59:29 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-24 18:59:29 +0000
commita9c5cdd88e2ea2eb3d4a880ea0124bcc908b2b27 (patch)
tree1ddc359a4ba33c1303ce045d205b9498657d6d8a /packages/sylpheed
parent6af976abd7164a5471fa7e36fd4f598b8f96d4a4 (diff)
downloadopenembedded-a9c5cdd88e2ea2eb3d4a880ea0124bcc908b2b27.tar.gz
added sylpheed2.0.0rc bb and patch file
Diffstat (limited to 'packages/sylpheed')
-rw-r--r--packages/sylpheed/files/sylpheed-gnutls_2.0.0rc.patch92
-rw-r--r--packages/sylpheed/sylpheed_2.0.0rc.bb32
2 files changed, 124 insertions, 0 deletions
diff --git a/packages/sylpheed/files/sylpheed-gnutls_2.0.0rc.patch b/packages/sylpheed/files/sylpheed-gnutls_2.0.0rc.patch
new file mode 100644
index 0000000000..b0a03c6a32
--- /dev/null
+++ b/packages/sylpheed/files/sylpheed-gnutls_2.0.0rc.patch
@@ -0,0 +1,92 @@
+--- sylpheed-2.0.0beta6/config.h.in.old 2005-07-18 11:57:23.000000000 +0200
++++ sylpheed-2.0.0beta6/config.h.in 2005-07-18 11:59:57.000000000 +0200
+@@ -263,6 +263,9 @@
+ /* Define to 1 if your <sys/time.h> declares `struct tm'. */
+ #undef TM_IN_SYS_TIME
+
++/* Define if you use GnuTLS to support SSL. */
++#undef USE_GNUTLS
++
+ /* Define if you use GPGME to support OpenPGP. */
+ #undef USE_GPGME
+
+@@ -273,6 +276,9 @@
+ #undef USE_LDAP
+
+ /* Define if you use OpenSSL to support SSL. */
++#undef USE_OPENSSL
++
++/* Define if SSL is supported. */
+ #undef USE_SSL
+
+ /* Whether to use multithread or not */
+--- sylpheed-2.0.0beta6/configure.in.old 2005-07-18 12:00:24.000000000 +0200
++++ sylpheed-2.0.0beta6/configure.in 2005-07-18 12:04:33.000000000 +0200
+@@ -202,7 +202,8 @@
+ #include <openssl/opensslv.h>
+ ], [ return OPENSSL_VERSION_NUMBER; ],
+ [ AC_MSG_RESULT(yes)
+- AC_DEFINE(USE_SSL, 1, Define if you use OpenSSL to support SSL.) ],
++ AC_DEFINE(USE_SSL, 1, Define if SSL is supported.)
++ AC_DEFINE(USE_OPENSSL, 1, Define if you use OpenSSL to support SSL.) ],
+ [ AC_MSG_RESULT(no)
+ LIBS="$ac_save_LIBS"
+ ac_cv_enable_ssl=no ])
+@@ -211,6 +212,27 @@
+ AC_MSG_RESULT(no)
+ fi
+
++AC_ARG_ENABLE(gnutls,
++ [ --enable-gnutls Enable SSL support using GnuTLS [default=no]],
++ [ac_cv_enable_gnutls=$enableval], [ac_cv_enable_gnutls=no])
++AC_MSG_CHECKING([whether to use GnuTLS])
++if test $ac_cv_enable_gnutls = yes; then
++ AC_MSG_RESULT(yes)
++ AC_MSG_CHECKING([if GnuTLS is available])
++ LIBS="$LIBS -lgnutls-openssl"
++ AC_TRY_LINK([
++#include <gnutls/openssl.h>
++], [ return OPENSSL_VERSION_NUMBER; ],
++ [ AC_MSG_RESULT(yes)
++ AC_DEFINE(USE_SSL, 1, Define if SSL is supported.)
++ AC_DEFINE(USE_GNUTLS, 1, Define if you use GnuTLS to support SSL.) ],
++ [ AC_MSG_RESULT(no)
++ LIBS="$ac_save_LIBS"
++ ac_cv_enable_gnutls=no ])
++else
++ AC_MSG_RESULT(no)
++fi
++
+ dnl Check for X-Face support
+ AC_ARG_ENABLE(compface,
+ [ --disable-compface Do not use compface (X-Face)],
+@@ -350,6 +372,7 @@
+ echo "JPilot : $ac_cv_enable_jpilot"
+ echo "LDAP : $ac_cv_enable_ldap"
+ echo "OpenSSL : $ac_cv_enable_ssl"
++echo "GnuTLS : $ac_cv_enable_gnutls"
+ echo "iconv : $am_cv_func_iconv"
+ echo "compface : $ac_cv_enable_compface"
+ echo "IPv6 : $ac_cv_enable_ipv6"
+--- sylpheed-2.0.0beta6/src/ssl.h.old 2005-07-18 12:09:35.000000000 +0200
++++ sylpheed-2.0.0beta6/src/ssl.h 2005-07-18 12:11:15.000000000 +0200
+@@ -27,11 +27,19 @@
+ #if USE_SSL
+
+ #include <glib.h>
++#if USE_OPENSSL
+ #include <openssl/crypto.h>
+ #include <openssl/x509.h>
+ #include <openssl/pem.h>
+ #include <openssl/ssl.h>
+ #include <openssl/err.h>
++#else
++#if USE_GNUTLS
++#include <gnutls/openssl.h>
++#else
++#error Must select either GnuTLS or OpenSSL
++#endif
++#endif
+
+ #include "socket.h"
+
diff --git a/packages/sylpheed/sylpheed_2.0.0rc.bb b/packages/sylpheed/sylpheed_2.0.0rc.bb
new file mode 100644
index 0000000000..531d694f98
--- /dev/null
+++ b/packages/sylpheed/sylpheed_2.0.0rc.bb
@@ -0,0 +1,32 @@
+SECTION = "x11/network"
+DESCRIPTION = "Mail user agent"
+DEPENDS = "gtk+ gpgme gnutls"
+MAINTAINER = "Patrick Steiner <patrick.steiner@a1.net>"
+LICENSE = "GPL"
+PR = "r3"
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://sylpheed.good-day.net/sylpheed/v2.0beta/sylpheed-2.0.0rc.tar.bz2 \
+ file://sylpheed-gnutls_2.0.0rc.patch;patch=1 \
+ file://sylpheed-gnutls-extra.patch;patch=1 "
+
+FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
+FILES_${PN}-doc += "${datadir}"
+
+EXTRA_OECONF = "--enable-gnutls"
+
+CFLAGS += "-D_GNU_SOURCE"
+
+do_configure_prepend() {
+ mkdir -p m4
+}
+
+inherit autotools
+
+do_install_append() {
+ install -d ${D}${datadir}/applications
+ install -m 0644 sylpheed.desktop ${D}${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps
+ install -m 0644 sylpheed.png ${D}${datadir}/pixmaps/
+}
+