aboutsummaryrefslogtreecommitdiffstats
path: root/packages/sysvinit
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-12-14 12:49:04 +0000
commitfe938bbed352811a2e176797d9f5295d270564e8 (patch)
treeb482ac8d4bbe1d878d08b41d7f73d95b00459474 /packages/sysvinit
parent8c45dce3743063bf4f15c5c17597fbeb15061d5f (diff)
downloadopenembedded-fe938bbed352811a2e176797d9f5295d270564e8.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2004/12/14 12:27:14+01:00 (none)!br1 Merge http://oe-devel@oe-devel.bkbits.net/openembedded into null.(none):/data/mtx/oe/openembedded 2004/12/14 12:26:43+01:00 (none)!br1 add mtx-1 i2c support 2004/12/14 11:02:03+01:00 (none)!br1 unik-olsrd 0.4.8 2004/12/14 11:00:53+01:00 (none)!br1 little fixes for bitbake 2004/12/14 10:59:06+01:00 (none)!br1 nylon updates 2004/12/14 03:27:14-06:00 ti.com!kergoth More PACKAGE_ARCH/MACHINE_ARCH updates for the multi-z builds. BKrev: 41bee140kQ_QwKwcIxgyouZUyeqwmA
Diffstat (limited to 'packages/sysvinit')
-rw-r--r--packages/sysvinit/sysvinit_2.85.bb94
-rw-r--r--packages/sysvinit/sysvinit_2.86.bb87
2 files changed, 181 insertions, 0 deletions
diff --git a/packages/sysvinit/sysvinit_2.85.bb b/packages/sysvinit/sysvinit_2.85.bb
index e69de29bb2..bb4605b79c 100644
--- a/packages/sysvinit/sysvinit_2.85.bb
+++ b/packages/sysvinit/sysvinit_2.85.bb
@@ -0,0 +1,94 @@
+SECTION = "base"
+DESCRIPTION = "System-V like init.\
+ Init is the first program to run after your system is booted, and\
+ continues to run as process number 1 until your system halts. Inits\
+ job is to start other programs that are essential to the operation of\
+ your system. All processes are descended from init. For more information,\
+ see the manual page init(8)."
+PACKAGES = "sysvinit"
+FILES_${PN} = "/sbin ${bindir} ${sysconfdir}"
+FILES_sysv-rc = "${sbindir}"
+PR = "r1"
+
+# USE_VT and SERIAL_CONSLE are generally defined by the MACHINE .conf.
+# Set PACKAGE_ARCH appropriately.
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+USE_VT ?= "1"
+
+SRC_URI = "ftp://ftp.cistron.nl/pub/people/miquels/sysvinit/sysvinit-${PV}.tar.gz \
+ file://need \
+ file://provide \
+ file://inittab \
+ file://rcS-default \
+ file://rc \
+ file://rcS"
+S = "${WORKDIR}/sysvinit-${PV}/src"
+
+CFLAGS_prepend = "-D_GNU_SOURCE "
+export LCRYPT = "-lcrypt"
+
+
+do_install () {
+ install -d ${D}/${bindir} ${D}/${sbindir} \
+ ${D}/sbin ${D}/${sysconfdir}/default \
+ ${D}/${sysconfdir}/init.d
+ install -m 755 halt killall5 \
+ runlevel shutdown ${D}/sbin/
+ install -m 755 init ${D}/sbin/sysvinit
+ install -m 755 mesg last ${D}${bindir}
+ install -m 0755 ${WORKDIR}/need ${D}/sbin/need.sysvinit
+ install -m 0755 ${WORKDIR}/provide ${D}/sbin/provide.sysvinit
+ ln -sf halt ${D}/sbin/reboot
+ ln -sf halt ${D}/sbin/poweroff
+ ln -sf init ${D}/sbin/telinit
+ ln -sf killall5 ${D}/sbin/pidof
+ ln -sf last ${D}${bindir}/lastb
+ install -m 0644 ${WORKDIR}/inittab ${D}/${sysconfdir}/inittab
+ if [ ! -z "${SERIAL_CONSOLE}" ]; then
+ echo "S:2345:respawn:/sbin/getty ${SERIAL_CONSOLE}" >> ${D}/etc/inittab
+ fi
+ if [ "${USE_VT}" == "1" ]; then
+ cat <<EOF >>${D}/etc/inittab
+# /sbin/getty invocations for the runlevels.
+#
+# The "id" field MUST be the same as the last
+# characters of the device (after "tty").
+#
+# Format:
+# <id>:<runlevels>:<action>:<process>
+#
+1:2345:respawn:/sbin/getty 38400 tty1
+# 2:23:respawn:/sbin/getty 38400 tty2
+# 3:23:respawn:/sbin/getty 38400 tty3
+# 4:23:respawn:/sbin/getty 38400 tty4
+EOF
+ fi
+ install -m 0644 ${WORKDIR}/rcS-default ${D}/etc/default/rcS
+ install -m 0755 ${WORKDIR}/rc ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/rcS ${D}/etc/init.d
+}
+
+
+do_install_append_ramses () {
+ cat <<EOF >>${D}/etc/inittab
+# Bluetooth
+#1:2345:respawn:/sbin/getty -L 115200 tts/1
+# External serial port
+4:2345:respawn:/sbin/getty -L 115200 tts/4
+# Framebuffer
+v1:2345:respawn:/sbin/getty -L 115200 vc/1
+EOF
+}
+
+
+pkg_postinst () {
+set -e
+# FIXME: use update-alternatives.. but what if the user doesnt have it?
+#if [ -n "`which update-alternatives 2>/dev/null`" ]; then
+# update-alternatives blah
+#else
+ ln -sf sysvinit $D/sbin/init
+#fi
+exit 0
+}
diff --git a/packages/sysvinit/sysvinit_2.86.bb b/packages/sysvinit/sysvinit_2.86.bb
index e69de29bb2..9a0bcaf8fa 100644
--- a/packages/sysvinit/sysvinit_2.86.bb
+++ b/packages/sysvinit/sysvinit_2.86.bb
@@ -0,0 +1,87 @@
+SECTION = "base"
+DESCRIPTION = "System-V like init."
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+HOMEPAGE = "http://freshmeat.net/projects/sysvinit/"
+
+FILES_${PN} += "/sbin /bin"
+PR = "r1"
+
+# USE_VT and SERIAL_CONSLE are generally defined by the MACHINE .conf.
+# Set PACKAGE_ARCH appropriately.
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+USE_VT ?= "1"
+
+SRC_URI = "ftp://ftp.cistron.nl/pub/people/miquels/sysvinit/sysvinit-2.85.tar.gz \
+ file://sysvinit-2.86.patch;patch=1 \
+ file://install.patch;patch=1 \
+ file://need \
+ file://provide \
+ file://inittab \
+ file://rcS-default \
+ file://rc \
+ file://rcS \
+ file://bootlogd.init"
+S = "${WORKDIR}/sysvinit-2.85"
+B = "${S}/src"
+
+CFLAGS_prepend = "-D_GNU_SOURCE "
+export LCRYPT = "-lcrypt"
+EXTRA_OEMAKE += "'INSTALL=install' \
+ 'bindir=/bin' \
+ 'sbindir=/sbin' \
+ 'usrbindir=${bindir}' \
+ 'usrsbindir=${sbindir}' \
+ 'includedir=${includedir}' \
+ 'mandir=${mandir}'"
+
+do_install () {
+ oe_runmake 'ROOT=${D}' install
+ install -d ${D}/${sysconfdir} \
+ ${D}/${sysconfdir}/default \
+ ${D}/${sysconfdir}/init.d
+ install -m 0644 ${WORKDIR}/inittab ${D}/${sysconfdir}/inittab
+ if [ ! -z "${SERIAL_CONSOLE}" ]; then
+ echo "S:2345:respawn:/sbin/getty ${SERIAL_CONSOLE}" >> ${D}/etc/inittab
+ fi
+ if [ "${USE_VT}" == "1" ]; then
+ cat <<EOF >>${D}/etc/inittab
+# /sbin/getty invocations for the runlevels.
+#
+# The "id" field MUST be the same as the last
+# characters of the device (after "tty").
+#
+# Format:
+# <id>:<runlevels>:<action>:<process>
+#
+1:2345:respawn:/sbin/getty 38400 tty1
+# 2:23:respawn:/sbin/getty 38400 tty2
+# 3:23:respawn:/sbin/getty 38400 tty3
+# 4:23:respawn:/sbin/getty 38400 tty4
+EOF
+ fi
+ install -m 0644 ${WORKDIR}/rcS-default ${D}/etc/default/rcS
+ install -m 0755 ${WORKDIR}/rc ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/rcS ${D}/etc/init.d
+ install -m 0755 ${WORKDIR}/bootlogd.init ${D}/etc/init.d/bootlogd
+ ln -sf bootlogd ${D}/etc/init.d/stop-bootlogd
+ install -d ${D}/etc/rcS.d
+ ln -sf ../init.d/bootlogd ${D}/etc/rcS.d/S07bootlogd
+ for level in 2 3 4 5; do
+ install -d ${D}/etc/rc$level.d
+ ln -s ../init.d/stop-bootlogd ${D}/etc/rc$level.d/
+ done
+}
+
+
+do_install_append_ramses () {
+ cat <<EOF >>${D}/etc/inittab
+# Bluetooth
+#1:2345:respawn:/sbin/getty -L 115200 tts/1
+# External serial port
+4:2345:respawn:/sbin/getty -L 115200 tts/4
+# Framebuffer
+v1:2345:respawn:/sbin/getty -L 115200 vc/1
+EOF
+}