aboutsummaryrefslogtreecommitdiffstats
path: root/packages/taglib
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-08-14 16:30:39 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-14 16:30:39 +0000
commit1e9f32efa15fcc6649119f0c4c398b3405f6b9c0 (patch)
treee5ebda6b98d48ee80f0a50acdd7f49e88d5a9d33 /packages/taglib
parentb9d4b2ee6ab16882d0d2a64fc50463cbdcdd0439 (diff)
downloadopenembedded-1e9f32efa15fcc6649119f0c4c398b3405f6b9c0.tar.gz
taglib: fix SOname and link against stdlibc++
Diffstat (limited to 'packages/taglib')
-rw-r--r--packages/taglib/taglib_1.4.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/packages/taglib/taglib_1.4.bb b/packages/taglib/taglib_1.4.bb
index 2fbd4dc334..48aa375048 100644
--- a/packages/taglib/taglib_1.4.bb
+++ b/packages/taglib/taglib_1.4.bb
@@ -2,16 +2,19 @@ DESCRIPTION = "TagLib is a library for reading and editing the meta-data of seve
SECTION = "libs"
HOMEPAGE = "http://developer.kde.org/~wheeler/taglib.html"
LICENSE = "LGPL"
+PR = "r1"
SRC_URI = "http://developer.kde.org/~wheeler/files/src/taglib-${PV}.tar.gz"
S = "${WORKDIR}/taglib-${PV}"
inherit autotools qmake-base pkgconfig binconfig
+export OE_QMAKE_LINK="${CXX}"
+
do_configure() {
# calling oe_runconf to generate pkgconfig and binconfig files
oe_runconf
- cd ${S}/taglib && rm -f Makefile* && qmake -project -t lib && \
+ cd ${S}/taglib && rm -f Makefile* && qmake -project -o tag.pro -t lib && \
qmake -spec ${QMAKESPEC} -after CONFIG=console INCLUDEPATH+=${S}
}
@@ -29,10 +32,10 @@ do_stage_append() {
do
install $i ${STAGING_INCDIR}/taglib/
done
- oe_libinstall -so -C taglib libtaglib ${STAGING_LIBDIR}
+ oe_libinstall -so -C taglib libtag ${STAGING_LIBDIR}
}
do_install() {
install -d ${D}${libdir}
- oe_libinstall -so -C taglib libtaglib ${D}${libdir}
+ oe_libinstall -so -C taglib libtag ${D}${libdir}
}