aboutsummaryrefslogtreecommitdiffstats
path: root/packages/thc
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-05-17 07:39:41 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-05-17 07:39:41 +0000
commitfd6ae25bd8e7bf29c8b8bc73e8c29c1d08f2c84d (patch)
treef367f5e01e66699443fa9fb667b2606f2e19355d /packages/thc
parent61c7a855ce4b3a7d302714080e21e5a832b90041 (diff)
downloadopenembedded-fd6ae25bd8e7bf29c8b8bc73e8c29c1d08f2c84d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/05/17 09:21:11+02:00 mn-solutions.de!schurig added/fixed HOMEPAGE BKrev: 42899fbdzXrdSdKQd7rQ9lh-S_Oh7w
Diffstat (limited to 'packages/thc')
-rw-r--r--packages/thc/hydra_4.5.bb27
-rw-r--r--packages/thc/thcrut_1.2.5.bb16
2 files changed, 43 insertions, 0 deletions
diff --git a/packages/thc/hydra_4.5.bb b/packages/thc/hydra_4.5.bb
index e69de29bb2..42134be724 100644
--- a/packages/thc/hydra_4.5.bb
+++ b/packages/thc/hydra_4.5.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A very fast network logon cracker which support many different services"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+HOMEPAGE = "http://thc.org/thc-hydra/"
+SECTION = "console/network"
+DEPENDS = "openssl"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://thc.org/releases/hydra-${PV}-src.tar.gz"
+S = "${WORKDIR}/hydra-${PV}-src"
+
+inherit autotools
+
+do_configure() {
+ echo "Now that's a sucky build system..."
+ cp -f Makefile.am Makefile
+}
+
+BINARIES = "pw-inspector hydra"
+
+do_install() {
+ install -d ${D}${bindir}
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${bindir}
+ done
+}
diff --git a/packages/thc/thcrut_1.2.5.bb b/packages/thc/thcrut_1.2.5.bb
index e69de29bb2..57e91d3417 100644
--- a/packages/thc/thcrut_1.2.5.bb
+++ b/packages/thc/thcrut_1.2.5.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "RUT (aRe-yoU-There) RUT gathers informations from local and remote networks"
+SECTION = "console/network"
+DEPENDS = "openssl libnet"
+HOMEPAGE = "http://thc.org/thc-rut/"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://packetstorm.linuxsecurity.com/groups/thc/thcrut-1.2.5.tar.gz \
+ file://configure_in.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/thcrut-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-ssl=${STAGING_LIBDIR}/.."
+