aboutsummaryrefslogtreecommitdiffstats
path: root/packages/thttpd
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-08-02 18:22:45 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-02 18:22:45 +0000
commitae09b22936efb65b90d1a658d4030a75ee567fcb (patch)
treea580b91cc1dc9bd00e056b715dd9a5fedf903be0 /packages/thttpd
parentf91e2d8febcca3bc8050b08579b61e63d0fd3081 (diff)
downloadopenembedded-ae09b22936efb65b90d1a658d4030a75ee567fcb.tar.gz
Added update-rc.d in postinst
Diffstat (limited to 'packages/thttpd')
-rw-r--r--packages/thttpd/thttpd_2.25b.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/packages/thttpd/thttpd_2.25b.bb b/packages/thttpd/thttpd_2.25b.bb
index 9a3ac3af11..f33ff5924e 100644
--- a/packages/thttpd/thttpd_2.25b.bb
+++ b/packages/thttpd/thttpd_2.25b.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server."
LICENSE = "BSD"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
HOMEPAGE = "http://www.acme.com/software/thttpd/"
-PR="r2"
+PR="r3"
SRC_URI = "http://www.acme.com/software/thttpd/thttpd-2.25b.tar.gz \
file://install.patch;patch=1 \
@@ -27,3 +27,12 @@ do_install_append () {
cat ${WORKDIR}/init | sed -e 's,@@SRVDIR,${servicedir}/www,g' > ${WORKDIR}/thttpd
install -c -m 755 ${WORKDIR}/thttpd ${D}${sysconfdir}/init.d/thttpd
}
+
+pkg_postinst() {
+ update-rc.d thttpd defaults 67
+}
+
+pkg_postrm() {
+ update-rc.d thttpd remove
+}
+