aboutsummaryrefslogtreecommitdiffstats
path: root/packages/thttpd
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2005-07-14 21:14:25 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-14 21:14:25 +0000
commitf8420e0dc23431e9124a60f496aab7fe7877e89d (patch)
treea137709dd3a9e7bd8e3eb790079dbd0f01f0915e /packages/thttpd
parent2033d3ca9dd4fc5ab62ccbbc45e509c983eecc79 (diff)
downloadopenembedded-f8420e0dc23431e9124a60f496aab7fe7877e89d.tar.gz
Fixed so initscript starts thttpd with the right path
Diffstat (limited to 'packages/thttpd')
-rw-r--r--packages/thttpd/files/init8
-rw-r--r--packages/thttpd/thttpd_2.25b.bb5
2 files changed, 7 insertions, 6 deletions
diff --git a/packages/thttpd/files/init b/packages/thttpd/files/init
index fdcd0f4530..df6d64842c 100644
--- a/packages/thttpd/files/init
+++ b/packages/thttpd/files/init
@@ -13,7 +13,7 @@ test -x "$thttpd" || exit 0
case "$1" in
start)
echo -n "Starting thttpd"
- start-stop-daemon --start --quiet --exec $thttpd
+ start-stop-daemon --start --quiet --exec $thttpd -- -d @@SRVDIR
echo "."
;;
stop)
@@ -22,11 +22,11 @@ case "$1" in
echo "."
;;
reload|force-reload)
- start-stop-daemon --stop --quiet --signal 1 --exec $thttpd
+ start-stop-daemon --stop --quiet --signal 1 --exec $thttpd
;;
restart)
echo -n "Stopping thttpd"
- start-stop-daemon --stop --quiet --exec $thttpd
+ start-stop-daemon --stop --quiet --exec $thttpd -- -d @@SRVDIR
echo "."
echo -n "Waiting for thttpd to die off"
for i in 1 2 3 ;
@@ -36,7 +36,7 @@ case "$1" in
done
echo ""
echo -n "Starting thttpd"
- start-stop-daemon --start --quiet --exec $thttpd
+ start-stop-daemon --start --quiet --exec $thttpd -- -d @@SRVDIR
echo "."
;;
*)
diff --git a/packages/thttpd/thttpd_2.25b.bb b/packages/thttpd/thttpd_2.25b.bb
index e7b786c1b0..9a3ac3af11 100644
--- a/packages/thttpd/thttpd_2.25b.bb
+++ b/packages/thttpd/thttpd_2.25b.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server."
LICENSE = "BSD"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
HOMEPAGE = "http://www.acme.com/software/thttpd/"
-PR="r1"
+PR="r2"
SRC_URI = "http://www.acme.com/software/thttpd/thttpd-2.25b.tar.gz \
file://install.patch;patch=1 \
@@ -24,5 +24,6 @@ do_configure () {
do_install_append () {
install -d "${D}${sysconfdir}/init.d"
- install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/thttpd
+ cat ${WORKDIR}/init | sed -e 's,@@SRVDIR,${servicedir}/www,g' > ${WORKDIR}/thttpd
+ install -c -m 755 ${WORKDIR}/thttpd ${D}${sysconfdir}/init.d/thttpd
}