aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tickypip
diff options
context:
space:
mode:
authorPaul Eggleton <bluelightning@bluelightning.org>2008-11-18 22:10:30 +0000
committerPaul Eggleton <bluelightning@bluelightning.org>2008-11-18 22:14:27 +0000
commit25fcf6f8ff9793aa51c6256ee432b2722faca8e1 (patch)
treec48689d5983af590a28bb2f20c644bad4d87b961 /packages/tickypip
parent46e30ed6ebb1a872f919363c6ff047344049079c (diff)
downloadopenembedded-25fcf6f8ff9793aa51c6256ee432b2722faca8e1.tar.gz
tickypip: fix fetching and path issues
* Fetch source from OZ 3.5.4 sources since current ones are unavailable * Look for levels in directory where they are now being installed
Diffstat (limited to 'packages/tickypip')
-rw-r--r--packages/tickypip/tickypip-levels_1.1.bb2
-rw-r--r--packages/tickypip/tickypip/path_fix.patch11
-rw-r--r--packages/tickypip/tickypip_0.1.2.bb7
3 files changed, 16 insertions, 4 deletions
diff --git a/packages/tickypip/tickypip-levels_1.1.bb b/packages/tickypip/tickypip-levels_1.1.bb
index c24044a168..91938cf2e6 100644
--- a/packages/tickypip/tickypip-levels_1.1.bb
+++ b/packages/tickypip/tickypip-levels_1.1.bb
@@ -8,7 +8,7 @@ RDEPENDS = "tickypip"
PACKAGE_ARCH = "all"
PR = "r1"
-SRC_URI = "http://ewi546.ewi.utwente.nl/mirror/hrw-oe-sources/tickypip-levels_${PV}.tar.bz2"
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/tickypip-levels_${PV}.tar.bz2"
S = "${WORKDIR}/"
diff --git a/packages/tickypip/tickypip/path_fix.patch b/packages/tickypip/tickypip/path_fix.patch
new file mode 100644
index 0000000000..c6e0b32f43
--- /dev/null
+++ b/packages/tickypip/tickypip/path_fix.patch
@@ -0,0 +1,11 @@
+--- tickypip/src/base.h 2008-11-18 21:49:58.000000000 +0000
++++ tickypip/src/base.h 2008-11-18 21:54:00.000000000 +0000
+@@ -7,7 +7,7 @@
+ #ifdef LOCAL_COMPILE
+ # define DATA_PREFIX "./"
+ #else
+-# define DATA_PREFIX "/opt/QtPalmtop/share/tickypip/"
++# define DATA_PREFIX DATA_BASEDIR "/share/tickypip/"
+ #endif
+
+ #include "BorderLayout.h"
diff --git a/packages/tickypip/tickypip_0.1.2.bb b/packages/tickypip/tickypip_0.1.2.bb
index 782803ba96..558828e919 100644
--- a/packages/tickypip/tickypip_0.1.2.bb
+++ b/packages/tickypip/tickypip_0.1.2.bb
@@ -5,9 +5,10 @@ LICENSE = "GPL"
AUTHOR = "Christian Hammond"
HOMEPAGE = "http://www.chipx86.com/projects/tickypip/"
RRECOMMENDS = "tickypip-levels"
-PR = "r4"
+PR = "r5"
-SRC_URI = "http://www.chipx86.com/packages/ipkg/tickypip-0.1.2.tar.gz \
+SRC_URI = "http://www.openzaurus.org/download/3.5.4/sources/tickypip-0.1.2.tar.gz \
+ file://path_fix.patch;patch=1 \
file://tickypip.desktop \
file://tickypip.png"
@@ -16,7 +17,7 @@ APPTYPE = "binary"
APPDESKTOP = "${WORKDIR}"
QMAKE_PROFILES = "tickypip.pro"
-EXTRA_QMAKEVARS_POST += "DEFINES-=LOCAL_COMPILE"
+EXTRA_QMAKEVARS_POST += "DEFINES-=LOCAL_COMPILE DEFINES+=DATA_BASEDIR='\"${palmtopdir}\"'"
do_install () {
install -d ${D}${palmtopdir}/pics/${APPNAME}/