aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tmdns
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/tmdns
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/tmdns')
-rw-r--r--packages/tmdns/.mtn2git_empty0
-rw-r--r--packages/tmdns/tmdns-20030116/.mtn2git_empty0
-rw-r--r--packages/tmdns/tmdns-20030116/busybox-init.d.patch61
-rw-r--r--packages/tmdns/tmdns-20030116/char-signed-idiocy.patch16
-rw-r--r--packages/tmdns/tmdns-20030116/install-init.d.patch28
-rw-r--r--packages/tmdns/tmdns_20030116.bb15
6 files changed, 120 insertions, 0 deletions
diff --git a/packages/tmdns/.mtn2git_empty b/packages/tmdns/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tmdns/.mtn2git_empty
diff --git a/packages/tmdns/tmdns-20030116/.mtn2git_empty b/packages/tmdns/tmdns-20030116/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/tmdns/tmdns-20030116/.mtn2git_empty
diff --git a/packages/tmdns/tmdns-20030116/busybox-init.d.patch b/packages/tmdns/tmdns-20030116/busybox-init.d.patch
index e69de29bb2..cb7c24369c 100644
--- a/packages/tmdns/tmdns-20030116/busybox-init.d.patch
+++ b/packages/tmdns/tmdns-20030116/busybox-init.d.patch
@@ -0,0 +1,61 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tmdns/init.d/initscript~busybox-init.d
++++ tmdns/init.d/initscript
+@@ -2,34 +2,31 @@
+ #
+
+ PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+-DAEMON=/usr/local/sbin/tmdns
++DAEMON=`which tmdns 2>/dev/null`
+ NAME=tmdns
+ DESC="tmdns multicast DNS responder version 0.1"
+
+-test -f $DAEMON || exit 0
++test -n "$DAEMON" || exit 0
+
+ set -e
+
+ case "$1" in
+ start)
+ echo -n "Starting $DESC: "
+- start-stop-daemon --start --quiet --pidfile /var/run/tmdns.pid \
+- --exec $DAEMON
++ start-stop-daemon -S -x $DAEMON
+ echo "$NAME."
+ ;;
+
+ stop)
+ echo -n "Stopping $DESC: "
+- start-stop-daemon --stop --quiet --pidfile /var/run/tmdns.pid \
+- --exec $DAEMON
++ start-stop-daemon -X -x $DAEMON
+ rm -f /var/run/tmdns.pid
+ echo "$NAME."
+ ;;
+
+ reload)
+ echo "Reloading $DESC configuration files."
+- start-stop-daemon --stop --signal 1 --quiet --pidfile \
+- /var/run/tmdns.pid --exec $DAEMON
++ start-stop-daemon -X -s 1 -x $DAEMON
+ ;;
+
+ restart|force-reload)
+@@ -39,11 +36,9 @@
+ # just the same as "restart".
+ #
+ echo -n "Restarting $DESC: "
+- start-stop-daemon --stop --quiet --pidfile \
+- /var/run/$NAME.pid --exec $DAEMON
++ start-stop-daemon -X -x $DAEMON
+ sleep 1
+- start-stop-daemon --start --quiet --pidfile \
+- /var/run/$NAME.pid --exec $DAEMON
++ start-stop-daemon -S -x $DAEMON
+ echo "$NAME."
+ ;;
+
diff --git a/packages/tmdns/tmdns-20030116/char-signed-idiocy.patch b/packages/tmdns/tmdns-20030116/char-signed-idiocy.patch
index e69de29bb2..d2856e07f6 100644
--- a/packages/tmdns/tmdns-20030116/char-signed-idiocy.patch
+++ b/packages/tmdns/tmdns-20030116/char-signed-idiocy.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tmdns/server/tmdns.c~char-signed-idiocy
++++ tmdns/server/tmdns.c
+@@ -87,7 +87,7 @@
+ *****************************************************************************/
+ int get_options( int argc, char ** argv ) {
+
+- char c = 0;
++ int c = 0;
+ int dns_bridge = 0;
+ int not_daemon = 0;
+ int no_fork = 0;
diff --git a/packages/tmdns/tmdns-20030116/install-init.d.patch b/packages/tmdns/tmdns-20030116/install-init.d.patch
index e69de29bb2..7941df1d42 100644
--- a/packages/tmdns/tmdns-20030116/install-init.d.patch
+++ b/packages/tmdns/tmdns-20030116/install-init.d.patch
@@ -0,0 +1,28 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tmdns/init.d/Makefile.am~install-init.d
++++ tmdns/init.d/Makefile.am
+@@ -23,6 +23,7 @@
+ install:
+ if [ -f initscript ] ;\
+ then \
+- install -m 755 initscript $(DESTDIR)$(INIT_DIR)/tmdns ;\
++ install -d $(DESTDIR)$(INIT_DIR); \
++ install -m 755 initscript $(DESTDIR)$(INIT_DIR)/tmdns; \
+ fi
+
+--- tmdns/init.d/Makefile.in~install-init.d
++++ tmdns/init.d/Makefile.in
+@@ -274,7 +274,8 @@
+ install:
+ if [ -f initscript ] ;\
+ then \
+- install -m 755 initscript $(DESTDIR)$(INIT_DIR)/tmdns ;\
++ install -d $(DESTDIR)$(INIT_DIR); \
++ install -m 755 initscript $(DESTDIR)$(INIT_DIR)/tmdns; \
+ fi
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/packages/tmdns/tmdns_20030116.bb b/packages/tmdns/tmdns_20030116.bb
index e69de29bb2..9907a52285 100644
--- a/packages/tmdns/tmdns_20030116.bb
+++ b/packages/tmdns/tmdns_20030116.bb
@@ -0,0 +1,15 @@
+LICENSE = GPL
+SECTION = "console/network"
+DESCRIPTION = "tmdns is a multicast DNS server."
+
+SRC_URI = "cvs://anonymous:@cvs.sourceforge.net/cvsroot/zeroconf;module=tmdns;date=${PV} \
+ file://install-init.d.patch;patch=1 \
+ file://busybox-init.d.patch;patch=1 \
+ file://char-signed-idiocy.patch;patch=1"
+S = "${WORKDIR}/tmdns"
+
+inherit autotools
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' 'INIT_DIR=${sysconfdir}/init.d' install
+}