aboutsummaryrefslogtreecommitdiffstats
path: root/packages/tslib
diff options
context:
space:
mode:
authorHolger Schurig <schurig@mn-solutions.de>2005-02-16 09:36:20 +0000
committerHolger Schurig <schurig@mn-solutions.de>2005-02-16 09:36:20 +0000
commit1ed7222dbe8cbe224e74f82b87cc79c886dc317a (patch)
tree5bf7e931f8c6e53a83122f84bb503ee25dfcf6e4 /packages/tslib
parent0cfbb9858e86d866bbcd8c6aebe354c2afe04fb6 (diff)
downloadopenembedded-1ed7222dbe8cbe224e74f82b87cc79c886dc317a.tar.gz
misc fixes for tslib to work on MNCI Ramses with it's /dev/input/event1 touchscreen
BKrev: 42131414F1zFL4No-bum2G5eroQhnQ
Diffstat (limited to 'packages/tslib')
-rw-r--r--packages/tslib/tslib/event1.patch71
-rw-r--r--packages/tslib/tslib_cvs.bb2
2 files changed, 52 insertions, 21 deletions
diff --git a/packages/tslib/tslib/event1.patch b/packages/tslib/tslib/event1.patch
index 8e53b525a8..88cc3f3a2a 100644
--- a/packages/tslib/tslib/event1.patch
+++ b/packages/tslib/tslib/event1.patch
@@ -5,45 +5,76 @@
--- tslib/tests/ts_calibrate.c~event1
+++ tslib/tests/ts_calibrate.c
-@@ -180,7 +180,7 @@
+@@ -179,11 +179,7 @@
+ if( (tsdevice = getenv("TSLIB_TSDEVICE")) != NULL ) {
ts = ts_open(tsdevice,0);
} else {
- #ifdef USE_INPUT_API
+-#ifdef USE_INPUT_API
- ts = ts_open("/dev/input/event0", 0);
+-#else
+- ts = ts_open("/dev/touchscreen/ucb1x00", 0);
+-#endif /* USE_INPUT_API */
+ ts = ts_open("/dev/input/event1", 0);
- #else
- ts = ts_open("/dev/touchscreen/ucb1x00", 0);
- #endif /* USE_INPUT_API */
+ }
+
+ if (!ts) {
--- tslib/tests/ts_print.c~event1
+++ tslib/tests/ts_print.c
-@@ -29,7 +29,7 @@
+@@ -28,11 +28,7 @@
+ if( (tsdevice = getenv("TSLIB_TSDEVICE")) != NULL ) {
ts = ts_open(tsdevice,0);
} else {
- #ifdef USE_INPUT_API
+-#ifdef USE_INPUT_API
- ts = ts_open("/dev/input/event0", 0);
+-#else
+- ts = ts_open("/dev/touchscreen/ucb1x00", 0);
+-#endif /* USE_INPUT_API */
+ ts = ts_open("/dev/input/event1", 0);
- #else
- ts = ts_open("/dev/touchscreen/ucb1x00", 0);
- #endif /* USE_INPUT_API */
+ }
+
+ if (!ts) {
--- tslib/tests/ts_test.c~event1
+++ tslib/tests/ts_test.c
-@@ -121,7 +121,7 @@
+@@ -120,11 +120,7 @@
+ signal(SIGTERM, sig);
if ((tsdevice = getenv("TSLIB_TSDEVICE")) == NULL) {
- #ifdef USE_INPUT_API
+-#ifdef USE_INPUT_API
- tsdevice = strdup ("/dev/input/event0");
+-#else
+- tsdevice = strdup ("/dev/touchscreen/ucb1x00");
+-#endif /* USE_INPUT_API */
+ tsdevice = strdup ("/dev/input/event1");
- #else
- tsdevice = strdup ("/dev/touchscreen/ucb1x00");
- #endif /* USE_INPUT_API */
+ }
+
+ ts = ts_open (tsdevice, 0);
--- tslib/tests/ts_print_raw.c~event1
+++ tslib/tests/ts_print_raw.c
-@@ -29,7 +29,7 @@
+@@ -28,11 +28,7 @@
+ if( (tsdevice = getenv("TSLIB_TSDEVICE")) != NULL ) {
ts = ts_open(tsdevice,0);
} else {
- #ifdef USE_INPUT_API
+-#ifdef USE_INPUT_API
- ts = ts_open("/dev/input/event0", 0);
+-#else
+- ts = ts_open("/dev/touchscreen/ucb1x00", 0);
+-#endif /* USE_INPUT_API */
+ ts = ts_open("/dev/input/event1", 0);
- #else
- ts = ts_open("/dev/touchscreen/ucb1x00", 0);
- #endif /* USE_INPUT_API */
+ }
+
+ if (!ts) {
+--- tslib/tests/ts_harvest.c~event1
++++ tslib/tests/ts_harvest.c
+@@ -75,11 +75,7 @@
+ signal(SIGTERM, sig);
+
+ if ((tsdevice = getenv("TSLIB_TSDEVICE")) == NULL) {
+-#ifdef USE_INPUT_API
+- tsdevice = strdup ("/dev/input/event0");
+-#else
+- tsdevice = strdup ("/dev/touchscreen/ucb1x00");
+-#endif /* USE_INPUT_API */
++ tsdevice = strdup ("/dev/input/event1");
+ }
+
+ ts = ts_open (tsdevice, 0);
diff --git a/packages/tslib/tslib_cvs.bb b/packages/tslib/tslib_cvs.bb
index 9c0699df05..f4edae231b 100644
--- a/packages/tslib/tslib_cvs.bb
+++ b/packages/tslib/tslib_cvs.bb
@@ -24,7 +24,7 @@ inherit autotools
PACKAGES = "tslib-conf libts libts-dev tslib-tests tslib-calibrate"
EXTRA_OECONF = "--enable-shared"
-EXTRA_OECONF_append_ramses = " --enable-input --disable-ucb1x00 --disable-corgi --disable-collie --disable-h3600 --disable-mk712 --disable-arctic2"
+EXTRA_OECONF_ramses = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 "
EXTRA_OECONF_beagle = "--enable-shared --enable-h3600 --disable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00 "
do_stage () {