aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ttyrec
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2007-04-03 02:21:19 +0000
committerMatthias Hentges <oe@hentges.net>2007-04-03 02:21:19 +0000
commit464dab74c58df1b0670cff89e842a998d554f355 (patch)
tree89f1c71a87ebe075a39aa2b0128e7eac390de803 /packages/ttyrec
parent2101a73213e474cef3e4d17ef6759e713c3c903f (diff)
downloadopenembedded-464dab74c58df1b0670cff89e842a998d554f355.tar.gz
:
ttyrec: Add ttyrec, a tty recorder
Diffstat (limited to 'packages/ttyrec')
-rw-r--r--packages/ttyrec/.mtn2git_empty0
-rw-r--r--packages/ttyrec/files/.mtn2git_empty0
-rw-r--r--packages/ttyrec/files/Makefile.patch8
-rw-r--r--packages/ttyrec/ttyrec_1.0.8.bb42
4 files changed, 50 insertions, 0 deletions
diff --git a/packages/ttyrec/.mtn2git_empty b/packages/ttyrec/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ttyrec/.mtn2git_empty
diff --git a/packages/ttyrec/files/.mtn2git_empty b/packages/ttyrec/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ttyrec/files/.mtn2git_empty
diff --git a/packages/ttyrec/files/Makefile.patch b/packages/ttyrec/files/Makefile.patch
new file mode 100644
index 0000000000..4c2f5774af
--- /dev/null
+++ b/packages/ttyrec/files/Makefile.patch
@@ -0,0 +1,8 @@
+--- ttyrec-1.0.8/Makefile.orig 2007-04-03 02:08:25.000000000 +0000
++++ ttyrec-1.0.8/Makefile 2007-04-03 02:08:42.000000000 +0000
+@@ -1,5 +1,3 @@
+-CC = gcc
+-CFLAGS = -O2
+ VERSION = 1.0.8
+
+ TARGET = ttyrec ttyplay ttytime
diff --git a/packages/ttyrec/ttyrec_1.0.8.bb b/packages/ttyrec/ttyrec_1.0.8.bb
new file mode 100644
index 0000000000..324751b4ba
--- /dev/null
+++ b/packages/ttyrec/ttyrec_1.0.8.bb
@@ -0,0 +1,42 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2007
+# License: MIT (see http://www.opensource.org/licenses/mit-license.php
+# for a copy of the license)
+#
+# Filename: ttyrec_1.0.8.bb
+# Date: 20070403 (YMD)
+
+DESCRIPTION = "ttyrec is a tty recorder. Recorded data can be played back with the included ttyplay command."
+MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
+HOMEPAGE = "http://0xcc.net/ttyrec/index.html.en"
+
+######################################################################################
+
+PR = "r0"
+
+######################################################################################
+
+SRC_URI = "http://0xcc.net/ttyrec/${PN}-${PV}.tar.gz \
+ file://Makefile.patch;patch=1"
+
+######################################################################################
+
+inherit autotools
+
+######################################################################################
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+######################################################################################
+
+do_install() {
+ install -d ${D}/usr/bin
+ install -d ${D}/usr/share/man/man1
+
+ for binary in ttyrec ttyplay ttytime
+ do
+ install -m 0755 ${S}/${binary} ${D}/usr/bin/
+ install -m 0644 ${S}/${binary}.1 ${D}/usr/share/man/man1
+ done
+}