aboutsummaryrefslogtreecommitdiffstats
path: root/packages/twisted
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2006-09-22 13:46:45 +0000
committerFelix Domke <tmbinc@elitedvb.ne>2006-09-22 13:46:45 +0000
commit36a4dc49b2bb91f18fbbd1212f6ed13ffc00af3e (patch)
tree9101a2a4de24711587724498abc5fadd527ff37b /packages/twisted
parentf1e0478df78445992099546828e38fccf75ed290 (diff)
downloadopenembedded-36a4dc49b2bb91f18fbbd1212f6ed13ffc00af3e.tar.gz
twisted-2.4.0: work around broken installscript
Diffstat (limited to 'packages/twisted')
-rw-r--r--packages/twisted/twisted_2.4.0.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/packages/twisted/twisted_2.4.0.bb b/packages/twisted/twisted_2.4.0.bb
index dca476859b..6fde50cdeb 100644
--- a/packages/twisted/twisted_2.4.0.bb
+++ b/packages/twisted/twisted_2.4.0.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.twistedmatrix.com"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "LGPL"
-DEPENDS = "zope-interface-native zope-interface python-crypto"
+DEPENDS = "zope-interface-native zope-interface python-crypto twisted-native"
RDEPENDS = "python-core zope-interface python-pickle python-fcntl python-crypto"
SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/2.4/Twisted-${PV}.tar.bz2"
@@ -14,3 +14,10 @@ S = "${WORKDIR}/Twisted-${PV}"
inherit distutils
+do_compile_prepend() {
+ export PYTHONPATH=${S}/TwistedCore-${PV}
+}
+
+do_install_prepend() {
+ export PYTHONPATH=${S}/TwistedCore-${PV}
+}