aboutsummaryrefslogtreecommitdiffstats
path: root/packages/u-boot
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2008-10-07 13:51:20 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2008-10-07 13:51:20 +0000
commit8e7b12439e33c351d8f5744898018509fd37cfe5 (patch)
tree3edb665aef663a2dc39b65af81e724090793d69f /packages/u-boot
parent821b74d1c59559496ed7e7e86531fe3f76f4dade (diff)
downloadopenembedded-8e7b12439e33c351d8f5744898018509fd37cfe5.tar.gz
mpc8313e-rdb: Merge Freescale's patches for u-boot 1.2.0 and linux 2.6.24.3.
Also make the u-boot version set conditionally rather than unconditionally, in the machine configuration file. Although u-boot 1.2.0 and 2.6.24.3 are reasonably outdated, the PCI Express support has never been merged upstream, neither to u-boot nor to linux, so use the above versions if you want to toy with PCI Express. It was extracted from MPC8315ERDB_20080627-ltib.iso, of which the patches are also available online at www.bitshrine.org.
Diffstat (limited to 'packages/u-boot')
-rw-r--r--packages/u-boot/u-boot_1.2.0.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/packages/u-boot/u-boot_1.2.0.bb b/packages/u-boot/u-boot_1.2.0.bb
index f1075bb00b..7c6aff8920 100644
--- a/packages/u-boot/u-boot_1.2.0.bb
+++ b/packages/u-boot/u-boot_1.2.0.bb
@@ -1,6 +1,6 @@
require u-boot.inc
-PR = "r2"
+PR = "r3"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-1.2.0.tar.bz2 \
"
@@ -22,4 +22,21 @@ do_compile_prepend_lsppchd () {
cp ${WORKDIR}/defconfig_lsppchd ${S}/include/configs/linkstation.h
}
+SRC_URI_append_mpc8315e-rdb = " \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pre.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-soc.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-PHY.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-platform.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-controller.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-boot.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-serdes.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pcie.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-fsl-1.3.0-MPC83xx-CW.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-silicon-1.1-1.2.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-extra-config-for-333-266MHz.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-resume-deep-sleep.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-improve-ddr-performance.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-fix-PCI-IO-base.patch;patch=1 \
+"
+
PACKAGE_ARCH = "${MACHINE_ARCH}"