aboutsummaryrefslogtreecommitdiffstats
path: root/packages/u-boot
diff options
context:
space:
mode:
authorJeremy Lainé <jeremy.laine@m4x.org>2008-11-21 16:09:54 +0100
committerJeremy Lainé <jeremy.laine@m4x.org>2008-11-21 16:09:54 +0100
commita9f20eab04d451b7dbb5d5881469ee40673420df (patch)
tree5a71f4ff5094559b67f60876ecdb31ee8386c304 /packages/u-boot
parentcbc6c0d81223c57b278708dffffd7f54f04f4d38 (diff)
downloadopenembedded-a9f20eab04d451b7dbb5d5881469ee40673420df.tar.gz
u-boot: cleanup boc01 patch for TSEC
Diffstat (limited to 'packages/u-boot')
-rw-r--r--packages/u-boot/u-boot-1.3.2/boc01/000_01_u-boot-1.3.2_LM73.patch25
-rw-r--r--packages/u-boot/u-boot-1.3.2/boc01/008_02_u-boot-1.3.2_TSEC.patch25
-rw-r--r--packages/u-boot/u-boot_1.3.2.bb2
3 files changed, 31 insertions, 21 deletions
diff --git a/packages/u-boot/u-boot-1.3.2/boc01/000_01_u-boot-1.3.2_LM73.patch b/packages/u-boot/u-boot-1.3.2/boc01/000_01_u-boot-1.3.2_LM73.patch
new file mode 100644
index 0000000000..97949d418e
--- /dev/null
+++ b/packages/u-boot/u-boot-1.3.2/boc01/000_01_u-boot-1.3.2_LM73.patch
@@ -0,0 +1,25 @@
+Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
+===================================================================
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-11-21 16:02:21.000000000 +0100
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-11-21 16:03:46.000000000 +0100
+@@ -364,6 +364,7 @@
+ #define CONFIG_CMD_PING
+ #define CONFIG_CMD_DHCP
+ #define CONFIG_CMD_I2C
++#define CONFIG_CMD_DTT
+ #define CONFIG_CMD_MII
+ #define CONFIG_CMD_DATE
+ #define CONFIG_CMD_PCI
+@@ -390,6 +391,12 @@
+ #define CFG_BARGSIZE CFG_CBSIZE /* Boot Argument Buffer Size */
+ #define CFG_HZ 1000 /* decrementer freq: 1ms ticks */
+
++/* Digital Thermometer and Thermostat */
++#define CONFIG_DTT_LM73 1
++#define CONFIG_DTT_SENSORS { 0x49 }
++#define CFG_DDT_MAX_TEMP 70
++#define CFG_DTT_MIN_TEMP -30
++
+ /*
+ * For booting Linux, the board info and command line data
+ * have to be in the first 8 MB of memory, since this is
diff --git a/packages/u-boot/u-boot-1.3.2/boc01/008_02_u-boot-1.3.2_TSEC.patch b/packages/u-boot/u-boot-1.3.2/boc01/008_02_u-boot-1.3.2_TSEC.patch
index 3dd89c5785..0fb8f17f65 100644
--- a/packages/u-boot/u-boot-1.3.2/boc01/008_02_u-boot-1.3.2_TSEC.patch
+++ b/packages/u-boot/u-boot-1.3.2/boc01/008_02_u-boot-1.3.2_TSEC.patch
@@ -1,7 +1,7 @@
Index: u-boot-1.3.2/drivers/net/tsec.c
===================================================================
--- u-boot-1.3.2.orig/drivers/net/tsec.c 2008-03-09 16:20:02.000000000 +0100
-+++ u-boot-1.3.2/drivers/net/tsec.c 2008-11-21 15:36:55.000000000 +0100
++++ u-boot-1.3.2/drivers/net/tsec.c 2008-11-21 16:06:21.000000000 +0100
@@ -179,6 +179,12 @@
priv->regs->maccfg1 |= MACCFG1_SOFT_RESET;
priv->regs->maccfg1 &= ~(MACCFG1_SOFT_RESET);
@@ -96,7 +96,7 @@ Index: u-boot-1.3.2/drivers/net/tsec.c
Index: u-boot-1.3.2/drivers/net/tsec.h
===================================================================
--- u-boot-1.3.2.orig/drivers/net/tsec.h 2008-03-09 16:20:02.000000000 +0100
-+++ u-boot-1.3.2/drivers/net/tsec.h 2008-11-21 15:36:55.000000000 +0100
++++ u-boot-1.3.2/drivers/net/tsec.h 2008-11-21 16:06:21.000000000 +0100
@@ -56,11 +56,11 @@
#define MACCFG1_SYNCD_TX_EN 0x00000002
#define MACCFG1_TX_EN 0x00000001
@@ -112,8 +112,8 @@ Index: u-boot-1.3.2/drivers/net/tsec.h
#define ECNTRL_TBI_MODE 0x00000020
Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
===================================================================
---- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-11-21 15:35:49.000000000 +0100
-+++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-11-21 15:37:39.000000000 +0100
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-11-21 16:06:16.000000000 +0100
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-11-21 16:06:21.000000000 +0100
@@ -245,8 +245,8 @@
#define CFG_BAUDRATE_TABLE \
{300, 600, 1200, 2400, 4800, 9600, 19200, 38400, 115200}
@@ -156,22 +156,7 @@ Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
/* Options are: TSEC[0-1] */
#define CONFIG_ETHPRIME "TSEC1"
-@@ -405,9 +406,11 @@
- #define CFG_HZ 1000 /* decrementer freq: 1ms ticks */
-
- /* Digital Thermometer and Thermostat */
--#define CONFIG_DTT_LM75 1
--#define CONFIG_DTT_SENSORS { 0x48 }
--
-+#define CONFIG_DTT_LM73 1
-+#define CONFIG_DTT_SENSORS { 0x49 }
-+#define CFG_DDT_MAX_TEMP 70
-+#define CFG_DTT_MIN_TEMP -30
-+
- /*
- * For booting Linux, the board info and command line data
- * have to be in the first 8 MB of memory, since this is
-@@ -453,17 +456,17 @@
+@@ -455,17 +456,17 @@
HRCWH_SW_WATCHDOG_DISABLE |\
HRCWH_ROM_LOC_LOCAL_16BIT |\
HRCWH_RL_EXT_LEGACY |\
diff --git a/packages/u-boot/u-boot_1.3.2.bb b/packages/u-boot/u-boot_1.3.2.bb
index 32282f16b8..21109b36ca 100644
--- a/packages/u-boot/u-boot_1.3.2.bb
+++ b/packages/u-boot/u-boot_1.3.2.bb
@@ -20,7 +20,7 @@ SRC_URI_append_mpc8313e-rdb = "\
SRC_URI_append_boc01 = "\
file://mpc8313e-rdb-nand.patch;patch=1 \
file://mpc8313e-rdb-eeprom.patch;patch=1 \
- file://mpc8313e-rdb-lm75.patch;patch=1 \
+ file://000_01_u-boot-1.3.2_LM73.patch;patch=1 \
file://001_01_u-boot-1.3.2_SPI.patch;patch=1 \
file://002_02_u-boot-1.3.2_GPIO.patch;patch=1 \
file://004_01_u-boot-1.3.2_WATCHDOG.patch;patch=1 \