aboutsummaryrefslogtreecommitdiffstats
path: root/packages/u-boot
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2008-09-12 16:56:37 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2008-09-12 16:56:37 +0000
commitcbb9e9ecfc1c79ec3b0b8991edd9ee685e69a4c5 (patch)
tree39d1446fe40581db404dee322b6958a0dbb379e7 /packages/u-boot
parent9f3781ab3c583f977cecc716440045cf91d7eee6 (diff)
downloadopenembedded-cbb9e9ecfc1c79ec3b0b8991edd9ee685e69a4c5.tar.gz
u-boot: massage mpc8313e-rdb patches so they apply cleanly
Diffstat (limited to 'packages/u-boot')
-rw-r--r--packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-autoboot.patch9
-rw-r--r--packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch23
2 files changed, 18 insertions, 14 deletions
diff --git a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-autoboot.patch b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-autoboot.patch
index ffca5a35c7..f844f29b0b 100644
--- a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-autoboot.patch
+++ b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-autoboot.patch
@@ -1,7 +1,8 @@
-diff -urN u-boot-1.3.1.orig/include/configs/MPC8313ERDB.h u-boot-1.3.1/include/configs/MPC8313ERDB.h
---- u-boot-1.3.1.orig/include/configs/MPC8313ERDB.h 2007-12-06 10:21:19.000000000 +0100
-+++ u-boot-1.3.1/include/configs/MPC8313ERDB.h 2008-01-31 17:38:10.000000000 +0100
-@@ -522,7 +522,7 @@
+Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
+===================================================================
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-03-09 16:20:02.000000000 +0100
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-09-12 18:08:16.000000000 +0200
+@@ -514,7 +514,7 @@
#define CONFIG_FDTFILE mpc8313erdb.dtb
#define CONFIG_LOADADDR 200000 /* default location for tftp and bootm */
diff --git a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch
index e653b75fb9..cd84565f94 100644
--- a/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch
+++ b/packages/u-boot/u-boot-1.3.2/mpc8313e-rdb-nand.patch
@@ -1,6 +1,7 @@
-diff -urN u-boot-1.3.1.orig/board/freescale/mpc8313erdb/Makefile u-boot-1.3.1/board/freescale/mpc8313erdb/Makefile
---- u-boot-1.3.1.orig/board/freescale/mpc8313erdb/Makefile 2007-12-06 10:21:19.000000000 +0100
-+++ u-boot-1.3.1/board/freescale/mpc8313erdb/Makefile 2008-01-31 17:35:43.000000000 +0100
+Index: u-boot-1.3.2/board/freescale/mpc8313erdb/Makefile
+===================================================================
+--- u-boot-1.3.2.orig/board/freescale/mpc8313erdb/Makefile 2008-03-09 16:20:02.000000000 +0100
++++ u-boot-1.3.2/board/freescale/mpc8313erdb/Makefile 2008-09-12 18:15:39.000000000 +0200
@@ -25,7 +25,7 @@
LIB = $(obj)lib$(BOARD).a
@@ -10,9 +11,10 @@ diff -urN u-boot-1.3.1.orig/board/freescale/mpc8313erdb/Makefile u-boot-1.3.1/bo
SRCS := $(SOBJS:.o=.S) $(COBJS:.o=.c)
OBJS := $(addprefix $(obj),$(COBJS))
-diff -urN u-boot-1.3.1.orig/board/freescale/mpc8313erdb/nand.c u-boot-1.3.1/board/freescale/mpc8313erdb/nand.c
---- u-boot-1.3.1.orig/board/freescale/mpc8313erdb/nand.c 1970-01-01 01:00:00.000000000 +0100
-+++ u-boot-1.3.1/board/freescale/mpc8313erdb/nand.c 2008-01-31 17:35:26.000000000 +0100
+Index: u-boot-1.3.2/board/freescale/mpc8313erdb/nand.c
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ u-boot-1.3.2/board/freescale/mpc8313erdb/nand.c 2008-09-12 18:15:39.000000000 +0200
@@ -0,0 +1,868 @@
+/*
+ * Copyright (C) Freescale Semiconductor, Inc. 2006.
@@ -882,10 +884,11 @@ diff -urN u-boot-1.3.1.orig/board/freescale/mpc8313erdb/nand.c u-boot-1.3.1/boar
+
+#endif
+#endif
-diff -urN u-boot-1.3.1.orig/include/configs/MPC8313ERDB.h u-boot-1.3.1/include/configs/MPC8313ERDB.h
---- u-boot-1.3.1.orig/include/configs/MPC8313ERDB.h 2007-12-06 10:21:19.000000000 +0100
-+++ u-boot-1.3.1/include/configs/MPC8313ERDB.h 2008-01-31 17:36:18.000000000 +0100
-@@ -360,6 +360,7 @@
+Index: u-boot-1.3.2/include/configs/MPC8313ERDB.h
+===================================================================
+--- u-boot-1.3.2.orig/include/configs/MPC8313ERDB.h 2008-09-12 18:15:39.000000000 +0200
++++ u-boot-1.3.2/include/configs/MPC8313ERDB.h 2008-09-12 18:15:39.000000000 +0200
+@@ -358,6 +358,7 @@
#define CONFIG_CMD_MII
#define CONFIG_CMD_DATE
#define CONFIG_CMD_PCI