aboutsummaryrefslogtreecommitdiffstats
path: root/packages/ubahnnav
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/ubahnnav
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/ubahnnav')
-rw-r--r--packages/ubahnnav/ubahnnav_0.3.1.bb32
-rw-r--r--packages/ubahnnav/ubahnnav_0.4.0.bb33
2 files changed, 65 insertions, 0 deletions
diff --git a/packages/ubahnnav/ubahnnav_0.3.1.bb b/packages/ubahnnav/ubahnnav_0.3.1.bb
index e69de29bb2..01d1a8a192 100644
--- a/packages/ubahnnav/ubahnnav_0.3.1.bb
+++ b/packages/ubahnnav/ubahnnav_0.3.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "U-Bahn Navigator helps you navigating through foreign public \
+transport networks. It finds the shortest or direct route from a start to a \
+destination station of the loaded subway map. U-Bahn Navigator is extensible \
+to support each public transport network."
+PRIORITY = "optional"
+SECTION = "opie/applications"
+MAINTAINER = "Dimitri Brukakis"
+LICENSE = "GPL"
+APPNAME = "ubahnnav"
+APPTYPE = "binary"
+APPDESKTOP = "${S}/src/ubahnnav"
+PR = "r2"
+
+SRC_URI = "http://ubahnstation.net/source/ubahnnav-${PV}.tar.gz \
+ file://qmake.patch;patch=1"
+S = "${WORKDIR}/ubahnnav-${PV}"
+
+inherit opie
+
+export OE_QMAKE_LINK="${CXX}"
+EXTRA_QMAKEVARS_POST = "LIBS+=-L${S}"
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+ oe_libinstall -so libsubwaymap ${D}${palmtopdir}/lib
+ install -d ${D}${palmtopdir}/pics ${D}${palmtopdir}/ubahn/maps
+ touch ${D}${palmtopdir}/ubahn/maps/.empty
+ install -m 0644 src/ubahnnav/images/u-logo.png ${D}${palmtopdir}/pics/ubahnnav.png
+}
diff --git a/packages/ubahnnav/ubahnnav_0.4.0.bb b/packages/ubahnnav/ubahnnav_0.4.0.bb
index e69de29bb2..49e46ac8b0 100644
--- a/packages/ubahnnav/ubahnnav_0.4.0.bb
+++ b/packages/ubahnnav/ubahnnav_0.4.0.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "U-Bahn Navigator helps you navigating through foreign public \
+transport networks. It finds the shortest or direct route from a start to a \
+destination station of the loaded subway map. U-Bahn Navigator is extensible \
+to support each public transport network."
+PRIORITY = "optional"
+SECTION = "opie/applications"
+AUTHOR = "Dimitri Brukakis"
+HOMEPAGE = "http://ubahnstation.net"
+LICENSE = "GPL"
+APPNAME = "ubahnnav"
+APPTYPE = "binary"
+APPDESKTOP = "${S}/src/ubahnnav"
+PR = "r2"
+
+SRC_URI = "http://ubahnstation.net/source/ubahnnav-${PV}.tar.gz \
+ file://qmake.patch;patch=1"
+S = "${WORKDIR}/ubahnnav-${PV}"
+
+inherit opie
+
+export OE_QMAKE_LINK="${CXX}"
+EXTRA_QMAKEVARS_POST = "LIBS+=-L${S} LIBS-=-lqtopia"
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+ oe_libinstall -so libsubwaymap ${D}${palmtopdir}/lib
+ install -d ${D}${palmtopdir}/pics ${D}${palmtopdir}/ubahn/maps
+ touch ${D}${palmtopdir}/ubahn/maps/.empty
+ install -m 0644 src/ubahnnav/images/u-logo.png ${D}${palmtopdir}/pics/ubahnnav.png
+}