aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uclibc/uclibc_0.9.28.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-09-22 19:44:38 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-22 19:44:38 +0000
commit4ab3322bcc988a6a0c0c1d2236d73e20b01dcf2e (patch)
treecb8ec7dcda091bcbce203d551fb80f2e4132be3e /packages/uclibc/uclibc_0.9.28.bb
parentcd49c7be0f05ac20ec76176f921936b00e1b2e8f (diff)
downloadopenembedded-4ab3322bcc988a6a0c0c1d2236d73e20b01dcf2e.tar.gz
uclibc_0.9.28: fix thumb support to allow thumb uclibc
This, together with the fixes in gcc and binutils, allows a system to be build with thumb libgcc and libuClibc (etc). ucslugc is changed to release 2 and to use thumb compilation of these modules.
Diffstat (limited to 'packages/uclibc/uclibc_0.9.28.bb')
-rw-r--r--packages/uclibc/uclibc_0.9.28.bb16
1 files changed, 11 insertions, 5 deletions
diff --git a/packages/uclibc/uclibc_0.9.28.bb b/packages/uclibc/uclibc_0.9.28.bb
index 8805f9ff2b..9214b64c0b 100644
--- a/packages/uclibc/uclibc_0.9.28.bb
+++ b/packages/uclibc/uclibc_0.9.28.bb
@@ -1,5 +1,5 @@
DEFAULT_PREFERENCE = "1"
-PR = "r2"
+PR = "r3"
include uclibc.inc
@@ -12,9 +12,6 @@ SRC_URI += "http://www.uclibc.org/downloads/uClibc-${PV}.tar.bz2"
S = "${WORKDIR}/uClibc-${PV}"
-# At present the thumb implementation is non-functional
-ARM_INSTRUCTION_SET = ""
-
#*** PATCHES ***
#
# The nokernelheadercheck patch removes the check on the include
@@ -29,4 +26,13 @@ SRC_URI += " file://thumb-defined-arm-or-thumb.patch;patch=1"
#
# Thumb interworking support
SRC_URI += " file://thumb-mov-pc-bx.patch;patch=1"
-SRC_URI += " file://thumb-resolve.patch;patch=1"
+SRC_URI += " file://thumb-swi-r7.patch;patch=1"
+SRC_URI += " file://thumb-sysnum-h.patch;patch=1"
+SRC_URI += " file://thumb-asm-swi.patch;patch=1"
+SRC_URI += " file://thumb-call-via-rx.patch;patch=1"
+#
+# This is a core change and is controversial, maybe even wrong
+# on some architectures
+THUMB_INTERWORK_RESOLVE_PATCH = ""
+THUMB_INTERWORK_RESOLVE_PATCH_thumb-interwork = " file://thumb-resolve.patch;patch=1"
+SRC_URI += " ${THUMB_INTERWORK_RESOLVE_PATCH}"