aboutsummaryrefslogtreecommitdiffstats
path: root/packages/udev
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-02-21 20:44:06 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-02-21 20:44:06 +0000
commitd46c1b4af2eb876e742c70e520612629745edb09 (patch)
treebbe5d75e7aae2862d4420f122cf0f6e2abab9d49 /packages/udev
parentb9e77e8d474c0d2016e9c23e9006b159e2ef0a59 (diff)
downloadopenembedded-d46c1b4af2eb876e742c70e520612629745edb09.tar.gz
udev: Fixup etc->sysconfdir, make sure sysconfdir/udev exists before writing into it
Diffstat (limited to 'packages/udev')
-rw-r--r--packages/udev/udev_092.bb5
-rw-r--r--packages/udev/udev_097.bb5
-rw-r--r--packages/udev/udev_100.bb5
3 files changed, 9 insertions, 6 deletions
diff --git a/packages/udev/udev_092.bb b/packages/udev/udev_092.bb
index 92e37de4f7..60783e92a4 100644
--- a/packages/udev/udev_092.bb
+++ b/packages/udev/udev_092.bb
@@ -68,9 +68,10 @@ pkg_postinst_append() {
if test "$mp" = "/"
then
root_partition="$dev"
- echo "$root_partition" >> /etc/udev/mount.blacklist
+ install -d ${sysconfdir}/udev
+ echo "$root_partition" >> ${sysconfdir}/udev/mount.blacklist
fi
- done < /etc/fstab
+ done < ${sysconfdir}/fstab
}
diff --git a/packages/udev/udev_097.bb b/packages/udev/udev_097.bb
index 84c414fd0d..d7cc3aa017 100644
--- a/packages/udev/udev_097.bb
+++ b/packages/udev/udev_097.bb
@@ -68,9 +68,10 @@ pkg_postinst_append() {
if test "$mp" = "/"
then
root_partition="$dev"
- echo "$root_partition" >> /etc/udev/mount.blacklist
+ install -d ${sysconfdir}/udev
+ echo "$root_partition" >> ${sysconfdir}/udev/mount.blacklist
fi
- done < /etc/fstab
+ done < ${sysconfdir}/fstab
}
diff --git a/packages/udev/udev_100.bb b/packages/udev/udev_100.bb
index 288157ef3f..4484f6e5b6 100644
--- a/packages/udev/udev_100.bb
+++ b/packages/udev/udev_100.bb
@@ -69,9 +69,10 @@ pkg_postinst_append() {
if test "$mp" = "/"
then
root_partition="$dev"
- echo "$root_partition" >> /etc/udev/mount.blacklist
+ install -d ${sysconfdir}/udev
+ echo "$root_partition" >> ${sysconfdir}/udev/mount.blacklist
fi
- done < /etc/fstab
+ done < ${sysconfdir}/fstab
}