aboutsummaryrefslogtreecommitdiffstats
path: root/packages/udev
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-08-12 10:56:38 +0000
committerKoen Kooi <koen@openembedded.org>2006-08-12 10:56:38 +0000
commit04fd73a240684af6964babf60e081b5f426b702e (patch)
treefcab6ca1c1ca78ccf5d9d043e49490c5329ef72c /packages/udev
parentcc681d72a2e5169dd1ee9557addda0172a140c5e (diff)
downloadopenembedded-04fd73a240684af6964babf60e081b5f426b702e.tar.gz
udev 092: fix hostap on h2200, courtesy Joshua Layne
Diffstat (limited to 'packages/udev')
-rw-r--r--packages/udev/udev-092/50-hostap_cs.rules4
-rw-r--r--packages/udev/udev_092.bb12
2 files changed, 14 insertions, 2 deletions
diff --git a/packages/udev/udev-092/50-hostap_cs.rules b/packages/udev/udev-092/50-hostap_cs.rules
new file mode 100644
index 0000000000..efefdc58fc
--- /dev/null
+++ b/packages/udev/udev-092/50-hostap_cs.rules
@@ -0,0 +1,4 @@
+# hostap_cs needs ignore_cis_vcc=1 set - this should handle all cards
+#
+ACTION=="add", DEVICE=="hostap_cs", \
+ SYSFS{func_id}=="0x06", RUN+="/sbin/modprobe hostap_cs ignore_cis_vcc=1"
diff --git a/packages/udev/udev_092.bb b/packages/udev/udev_092.bb
index 6a650b5f09..07b5eaa12f 100644
--- a/packages/udev/udev_092.bb
+++ b/packages/udev/udev_092.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "udev is a daemon which dynamically creates and removes device nod
the hotplug package and requires a kernel not older than 2.6.12."
RPROVIDES = "hotplug"
-PR = "r9"
+PR = "r10"
SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://noasmlinkage.patch;patch=1 \
@@ -11,7 +11,11 @@ SRC_URI = "http://kernel.org/pub/linux/utils/kernel/hotplug/udev-${PV}.tar.gz \
file://udevsynthesize.patch;patch=1 \
file://udevsynthesize.sh \
file://arm_inotify_fix.patch;patch=1 \
- file://mount.blacklist"
+ file://mount.blacklist \
+ "
+
+SRC_URI_append_h2200 = " file://50-hostap_cs.rules "
+PACKAGE_ARCH_h2200 = "h2200"
require udev.inc
@@ -49,3 +53,7 @@ do_install () {
install -m 0755 ${S}/udevsynthesize ${D}${base_libdir}/udev/udevsynthesize
install -m 0755 ${WORKDIR}/udevsynthesize.sh ${D}${sbindir}/udevsynthesize
}
+
+do_install_append_h2200() {
+ install -m 0644 ${WORKDIR}/50-hostap_cs.rules ${D}${sysconfdir}/udev/rules.d/50-hostap_cs.rules
+}