aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uicmoc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-14 10:05:43 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-14 10:05:43 +0000
commite753792321bbea656f91372a51fa0056aaf48571 (patch)
treebf6f846f0c10d85487a5b96b89cb4c32d7c797fe /packages/uicmoc
parente33f51d47289a43aaa412dc13e7473c16b4f68ea (diff)
downloadopenembedded-e753792321bbea656f91372a51fa0056aaf48571.tar.gz
uicmoc4: add sdk version, fix build with gcc 4.3.x
Diffstat (limited to 'packages/uicmoc')
-rw-r--r--packages/uicmoc/files/qapplication.diff132
-rw-r--r--packages/uicmoc/uicmoc4-native.inc2
-rw-r--r--packages/uicmoc/uicmoc4-native_4.3.1.bb2
-rw-r--r--packages/uicmoc/uicmoc4-native_4.3.3.bb1
-rw-r--r--packages/uicmoc/uicmoc4-native_4.4.0.bb5
-rw-r--r--packages/uicmoc/uicmoc4-sdk_4.4.0.bb23
6 files changed, 162 insertions, 3 deletions
diff --git a/packages/uicmoc/files/qapplication.diff b/packages/uicmoc/files/qapplication.diff
new file mode 100644
index 0000000000..4600f66bd3
--- /dev/null
+++ b/packages/uicmoc/files/qapplication.diff
@@ -0,0 +1,132 @@
+--- /tmp/qapplication_p.h 2008-07-14 11:39:24.000000000 +0200
++++ qt-embedded-linux-opensource-src-4.4.0/src/gui/kernel/qapplication_p.h 2008-07-14 11:39:47.000000000 +0200
+@@ -344,7 +344,7 @@
+ # endif
+ QRect maxWindowRect(const QScreen *screen) const { return maxWindowRects[screen]; }
+ void setMaxWindowRect(const QScreen *screen, int screenNo, const QRect &rect);
+- void setScreenTransformation(QScreen *screen, int screen, int transformation);
++ void setScreenTransformation(QScreen *screen, int screenNo, int transformation);
+ #endif
+
+ static QApplicationPrivate *instance() { return self; }
+--- /tmp/qdrawhelper_p.h 2008-07-14 11:48:26.000000000 +0200
++++ qt-embedded-linux-opensource-src-4.4.0/src/gui/painting/qdrawhelper_p.h 2008-07-14 11:50:12.000000000 +0200
+@@ -1379,7 +1379,7 @@
+ static inline quint32 qt_convertToRgb(SRC color);
+
+ template <>
+-static inline quint32 qt_convertToRgb(quint32 color)
++inline quint32 qt_convertToRgb(quint32 color)
+ {
+ const int r = qRed(color) >> (8 - qrgb::len_red);
+ const int g = qGreen(color) >> (8 - qrgb::len_green);
+@@ -1394,7 +1394,7 @@
+ }
+
+ template <>
+-static inline quint32 qt_convertToRgb(quint16 color)
++inline quint32 qt_convertToRgb(quint16 color)
+ {
+ return qt_convertToRgb(qt_colorConvert<quint32, quint16>(color, 0));
+ }
+@@ -1422,14 +1422,14 @@
+ } Q_PACKED;
+
+ template <>
+-static inline qrgb_generic16 qt_colorConvert(quint32 color, qrgb_generic16 dummy)
++inline qrgb_generic16 qt_colorConvert(quint32 color, qrgb_generic16 dummy)
+ {
+ Q_UNUSED(dummy);
+ return qrgb_generic16(color);
+ }
+
+ template <>
+-static inline qrgb_generic16 qt_colorConvert(quint16 color, qrgb_generic16 dummy)
++inline qrgb_generic16 qt_colorConvert(quint16 color, qrgb_generic16 dummy)
+ {
+ Q_UNUSED(dummy);
+ return qrgb_generic16(qt_colorConvert<quint32, quint16>(color, 0));
+--- /tmp/qscreen_qws.cpp 2008-07-14 11:51:39.000000000 +0200
++++ qt-embedded-linux-opensource-src-4.4.0/src/gui/embedded/qscreen_qws.cpp 2008-07-14 11:52:56.000000000 +0200
+@@ -828,13 +828,13 @@
+ static inline quint8 qt_convertToGray4(SRC color);
+
+ template <>
+-static inline quint8 qt_convertToGray4(quint32 color)
++inline quint8 qt_convertToGray4(quint32 color)
+ {
+ return qGray(color) >> 4;
+ }
+
+ template <>
+-static inline quint8 qt_convertToGray4(quint16 color)
++inline quint8 qt_convertToGray4(quint16 color)
+ {
+ const int r = (color & 0xf800) >> 11;
+ const int g = (color & 0x07e0) >> 6; // only keep 5 bit
+@@ -843,13 +843,13 @@
+ }
+
+ template <>
+-static inline quint8 qt_convertToGray4(qrgb444 color)
++inline quint8 qt_convertToGray4(qrgb444 color)
+ {
+ return qt_convertToGray4(quint32(color));
+ }
+
+ template <>
+-static inline quint8 qt_convertToGray4(qargb4444 color)
++inline quint8 qt_convertToGray4(qargb4444 color)
+ {
+ return qt_convertToGray4(quint32(color));
+ }
+@@ -969,25 +969,25 @@
+ static inline quint8 qt_convertToMono(SRC color);
+
+ template <>
+-static inline quint8 qt_convertToMono(quint32 color)
++inline quint8 qt_convertToMono(quint32 color)
+ {
+ return qGray(color) >> 7;
+ }
+
+ template <>
+-static inline quint8 qt_convertToMono(quint16 color)
++inline quint8 qt_convertToMono(quint16 color)
+ {
+ return (qGray(qt_colorConvert<quint32, quint16>(color, 0)) >> 7);
+ }
+
+ template <>
+-static inline quint8 qt_convertToMono(qargb4444 color)
++inline quint8 qt_convertToMono(qargb4444 color)
+ {
+ return (qGray(quint32(color)) >> 7);
+ }
+
+ template <>
+-static inline quint8 qt_convertToMono(qrgb444 color)
++inline quint8 qt_convertToMono(qrgb444 color)
+ {
+ return (qGray(quint32(color)) >> 7);
+ }
+--- /tmp/qdrawhelper.cpp 2008-07-14 11:56:25.000000000 +0200
++++ qt-embedded-linux-opensource-src-4.4.0/src/gui/painting/qdrawhelper.cpp 2008-07-14 11:57:29.000000000 +0200
+@@ -3374,7 +3374,7 @@
+
+ #if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
+ template <>
+-static inline void madd_4(qargb8565 *dest, const quint32 a, const qargb8565 *src)
++inline void madd_4(qargb8565 *dest, const quint32 a, const qargb8565 *src)
+ {
+ Q_ASSERT((quintptr(dest) & 0x3) == 0);
+ Q_ASSERT((quintptr(src) & 0x3) == 0);
+@@ -3455,7 +3455,7 @@
+
+ #if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
+ template <>
+-static inline void madd_4(qargb8555 *dest, const quint32 a, const qargb8555 *src)
++inline void madd_4(qargb8555 *dest, const quint32 a, const qargb8555 *src)
+ {
+ Q_ASSERT((quintptr(dest) & 0x3) == 0);
+ Q_ASSERT((quintptr(src) & 0x3) == 0);
diff --git a/packages/uicmoc/uicmoc4-native.inc b/packages/uicmoc/uicmoc4-native.inc
index c5adef71e4..8d7f3111dc 100644
--- a/packages/uicmoc/uicmoc4-native.inc
+++ b/packages/uicmoc/uicmoc4-native.inc
@@ -10,8 +10,6 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.ta
file://configure-fix.patch;patch=1"
S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
-inherit native
-
EXTRA_OECONF = "-prefix ${STAGING_DIR_NATIVE}/qt4 \
-qt-libjpeg -qt-gif -system-zlib \
-no-nis -no-cups -no-exceptions \
diff --git a/packages/uicmoc/uicmoc4-native_4.3.1.bb b/packages/uicmoc/uicmoc4-native_4.3.1.bb
index 1950f63068..dc969d4be1 100644
--- a/packages/uicmoc/uicmoc4-native_4.3.1.bb
+++ b/packages/uicmoc/uicmoc4-native_4.3.1.bb
@@ -1 +1,3 @@
require uicmoc4-native.inc
+
+inherit native
diff --git a/packages/uicmoc/uicmoc4-native_4.3.3.bb b/packages/uicmoc/uicmoc4-native_4.3.3.bb
index 1950f63068..dd1ac3d98d 100644
--- a/packages/uicmoc/uicmoc4-native_4.3.3.bb
+++ b/packages/uicmoc/uicmoc4-native_4.3.3.bb
@@ -1 +1,2 @@
require uicmoc4-native.inc
+inherit native
diff --git a/packages/uicmoc/uicmoc4-native_4.4.0.bb b/packages/uicmoc/uicmoc4-native_4.4.0.bb
index 6d9c83eb75..6e13ccbf13 100644
--- a/packages/uicmoc/uicmoc4-native_4.4.0.bb
+++ b/packages/uicmoc/uicmoc4-native_4.4.0.bb
@@ -1,7 +1,10 @@
require uicmoc4-native.inc
SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
- file://configure-fix.patch;patch=1"
+ file://configure-fix.patch;patch=1 \
+ file://qapplication.diff;patch=1 "
+
S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
+inherit native
diff --git a/packages/uicmoc/uicmoc4-sdk_4.4.0.bb b/packages/uicmoc/uicmoc4-sdk_4.4.0.bb
new file mode 100644
index 0000000000..00aeb26564
--- /dev/null
+++ b/packages/uicmoc/uicmoc4-sdk_4.4.0.bb
@@ -0,0 +1,23 @@
+require uicmoc4-native.inc
+
+inherit sdk
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-linux-opensource-src-${PV}.tar.bz2 \
+ file://configure-fix.patch;patch=1 \
+ file://qapplication.diff;patch=1 "
+
+S = "${WORKDIR}/qt-embedded-linux-opensource-src-${PV}"
+
+do_install_append() {
+ install -d ${D}/${bindir}
+ install -m 0755 bin/moc ${D}/${bindir}/moc4
+ install -m 0755 bin/uic ${D}/${bindir}/uic4
+ install -m 0755 bin/uic3 ${D}/${bindir}/uic34
+ install -m 0755 bin/rcc ${D}/${bindir}/rcc4
+ install -m 0755 bin/lrelease ${D}/${bindir}/lrelease4
+ install -m 0755 bin/lupdate ${D}/${bindir}/lupdate4
+ install -d ${D}/${datadir}/qt4/
+ install -m 0644 tools/porting/src/q3porting.xml ${D}/${datadir}/qt4/
+}
+
+