aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uicmoc
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2005-02-03 11:51:04 +0000
committerGraeme Gregory <dp@xora.org.uk>2005-02-03 11:51:04 +0000
commit5a6d8f6ce9dc9054dc2292a3c80a84779cb98c3d (patch)
tree87b202553c0adecf5a2a71e12ba66bc716e0f4c0 /packages/uicmoc
parent7083669ff18c6242cea42a9c4b74c7d1803b3152 (diff)
downloadopenembedded-5a6d8f6ce9dc9054dc2292a3c80a84779cb98c3d.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into cimmeria.(none):/home/dp/zaurus/openembedded 2005/02/03 10:16:58+00:00 (none)!xora Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into cimmeria.(none):/home/dp/zaurus/openembedded 2005/02/03 08:43:45+00:00 (none)!xora Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into cimmeria.(none):/home/dp/zaurus/openembedded 2005/02/02 12:21:06+00:00 (none)!xora Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into cimmeria.(none):/home/dp/zaurus/openembedded 2005/02/02 12:20:16+00:00 (none)!xora gcc3_4.patch, fix-makefile.patch: mvdir BKrev: 42021028q_tCZVnxLn41S6LjD2VTAg
Diffstat (limited to 'packages/uicmoc')
-rw-r--r--packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/fix-makefile.patch16
-rw-r--r--packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/gcc3_4.patch27
2 files changed, 43 insertions, 0 deletions
diff --git a/packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/fix-makefile.patch b/packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/fix-makefile.patch
index e69de29bb2..5943f0f17b 100644
--- a/packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/fix-makefile.patch
+++ b/packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/fix-makefile.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- qt-2.3.7/Makefile~fix-makefile 2003-07-17 03:23:11.000000000 +0200
++++ qt-2.3.7/Makefile 2004-04-23 15:36:25.000000000 +0200
+@@ -29,7 +29,7 @@
+ cd tools; $(MAKE)
+
+ symlinks: .buildopts
+- @cd include; rm -f q*.h; for i in ../src/*/q*.h ../src/3rdparty/*/q*.h ../extensions/*/src/q*.h; do ln -s $$i .; done; rm -f q*_p.h
++ @cd include; rm -f q*.h; for i in ../src/*/q*.h ../src/3rdparty/*/*.h ../extensions/*/src/q*.h; do ln -s $$i .; done; rm -f q*_p.h
+
+ sub-src: src-moc src-mt .buildopts FORCE
+ cd src; $(MAKE)
diff --git a/packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/gcc3_4.patch b/packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/gcc3_4.patch
index e69de29bb2..fc1656aa24 100644
--- a/packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/gcc3_4.patch
+++ b/packages/uicmoc/uicmoc-native-2.3.10-snapshot-20050131/gcc3_4.patch
@@ -0,0 +1,27 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- qt-2.3.9-snapshot-20041211/src/tools/qcstring.h~gcc3
++++ qt-2.3.9-snapshot-20041211/src/tools/qcstring.h
+@@ -119,7 +119,7 @@
+ // We want to keep source compatibility for 2.x
+ // ### TODO for 4.0: completely remove these and the cstr* functions
+
+-#if !defined(QT_GENUINE_STR)
++#if 0
+
+ #undef strlen
+ #define strlen qstrlen
+--- qt-2.3.9-snapshot-20041211/src/kernel/qwsdecoration_qws.h~gcc3
++++ qt-2.3.9-snapshot-20041211/src/kernel/qwsdecoration_qws.h
+@@ -50,7 +50,7 @@
+ enum Region { None=0, All=1, Title=2, Top=3, Bottom=4, Left=5, Right=6,
+ TopLeft=7, TopRight=8, BottomLeft=9, BottomRight=10,
+ Close=11, Minimize=12, Maximize=13, Normalize=14,
+- Menu=15, LastRegion=Menu };
++ Menu=15, LastRegion=Menu, UserDefined = 100 };
+
+ virtual QRegion region(const QWidget *, const QRect &rect, Region r=All) = 0;
+ virtual void close( QWidget * );